CVE-2025-26511 Cassandra-Lucene-Index allows bypass of Cassandra RBAC
Authenticated users can bypass RBAC and escalate privileges in Cassandra installations using the vulnerable Lucene Index plugin.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-26511?
CVE-2025-26511 is a high-severity authentication bypass vulnerability in NetApp Instaclustr fork of Stratio's Cassandra-Lucene-Index plugin, published on 13 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Systems running the Instaclustr fork of Stratio's Cassandra-Lucene-Index plugin versions 4.0-rc1-1.0.0 through 4.0.16-1.0.0 and 4.1.2-1.0.0 through 4.1.8-1.0.0, installed into Apache Cassandra version 4.x, are susceptible to a vulnerability which when successfully exploited could allow authenticated Cassandra users to remotely bypass RBAC and escalate their privileges.
Weakness: CWE-863
Which versions are affected by CVE-2025-26511?
4 open source packages ship an affected version, including com.instaclustr:cassandra-lucene-index-plugin.
| Package | Affected | Fixed in |
|---|---|---|
com.instaclustr:cassandra-lucene-index-plugin Maven | From 4.0-rc1-1.0.0 | 4.0.17-1.0.0 |
com.instaclustr:cassandra-lucene-index-plugin Maven | From 4.0-rc1-1.0.0 | 4.0.17-1.0.0 |
com.instaclustr:cassandra-lucene-index-plugin Maven | From 4.1.0-1.0.0 | 4.1.8-1.0.1 |
com.instaclustr:cassandra-lucene-index-plugin Maven | From 4.1.0-1.0.0 | 4.1.8-1.0.1 |
How do I fix CVE-2025-26511?
Upgrade com.instaclustr:cassandra-lucene-index-plugin to a fixed version for your release line: 4.0.17-1.0.0 or 4.1.8-1.0.1.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2025-26511 being exploited?
There is no known exploitation of CVE-2025-26511 in the wild and no public exploit code.
Sources
Also known as GHSA-mrqp-q7vx-v2cx.