{"answers":{"affected":"4 open source packages ship an affected version, including com.instaclustr:cassandra-lucene-index-plugin.","exploited":"There is no known exploitation of CVE-2025-26511 in the wild and no public exploit code.","fix":"Upgrade com.instaclustr:cassandra-lucene-index-plugin to a fixed version for your release line: 4.0.17-1.0.0 or 4.1.8-1.0.1.","what":"CVE-2025-26511 is a high-severity authentication bypass vulnerability in NetApp Instaclustr fork of Stratio's Cassandra-Lucene-Index plugin, published on 13 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-26511 and fix it if it is affected.\n\nWhat it is: CVE-2025-26511 is a high-severity authentication bypass vulnerability in NetApp Instaclustr fork of Stratio's Cassandra-Lucene-Index plugin, published on 13 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-26511 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.instaclustr:cassandra-lucene-index-plugin (Maven): affected from 4.0-rc1-1.0.0; fixed in 4.0.17-1.0.0\n- com.instaclustr:cassandra-lucene-index-plugin (Maven): affected from 4.0-rc1-1.0.0; fixed in 4.0.17-1.0.0\n- com.instaclustr:cassandra-lucene-index-plugin (Maven): affected from 4.1.0-1.0.0; fixed in 4.1.8-1.0.1\n- com.instaclustr:cassandra-lucene-index-plugin (Maven): affected from 4.1.0-1.0.0; fixed in 4.1.8-1.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-26511/ (Markdown: https://insights.sbomify.com/CVE-2025-26511/index.md)","id":"CVE-2025-26511","markdown":"https://insights.sbomify.com/CVE-2025-26511/index.md","name":"CVE-2025-26511","record":{"aliases":["GHSA-mrqp-q7vx-v2cx"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["privilege_escalation","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Cassandra Lucene Index","requires_auth":"low_privilege","summary":"Authenticated users can bypass RBAC and escalate privileges in Cassandra installations using the vulnerable Lucene Index plugin.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"netapp","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"Systems running the Instaclustr \nfork of Stratio's Cassandra-Lucene-Index plugin versions 4.0-rc1-1.0.0 \nthrough 4.0.16-1.0.0 and 4.1.2-1.0.0 through 4.1.8-1.0.0, installed into\n Apache Cassandra version 4.x, are susceptible to a vulnerability which \nwhen successfully exploited could allow authenticated Cassandra users to\n remotely bypass RBAC and escalate their privileges.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cassandra-Lucene-Index allows bypass of Cassandra RBAC","id":"CVE-2025-26511","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":4,"n_references":1,"next":{"headline":"CVE-2025-26512 Privilege Escalation Vulnerability in SnapCenter","id":"CVE-2025-26512"},"packages":[{"ecosystem":"Maven","fixed":["4.0.17-1.0.0"],"introduced":["4.0-rc1-1.0.0"],"last_affected":[],"package":"com.instaclustr:cassandra-lucene-index-plugin","purl":null,"source":"GHSA-mrqp-q7vx-v2cx"},{"ecosystem":"Maven","fixed":["4.0.17-1.0.0"],"introduced":["4.0-rc1-1.0.0"],"last_affected":[],"package":"com.instaclustr:cassandra-lucene-index-plugin","purl":"pkg:maven/com.instaclustr/cassandra-lucene-index-plugin","source":"GHSA-mrqp-q7vx-v2cx"},{"ecosystem":"Maven","fixed":["4.1.8-1.0.1"],"introduced":["4.1.0-1.0.0"],"last_affected":[],"package":"com.instaclustr:cassandra-lucene-index-plugin","purl":null,"source":"GHSA-mrqp-q7vx-v2cx"},{"ecosystem":"Maven","fixed":["4.1.8-1.0.1"],"introduced":["4.1.0-1.0.0"],"last_affected":[],"package":"com.instaclustr:cassandra-lucene-index-plugin","purl":"pkg:maven/com.instaclustr/cassandra-lucene-index-plugin","source":"GHSA-mrqp-q7vx-v2cx"}],"prev":{"headline":"Memory corruption in Certain HP LaserJet Pro, HP LaserJet Enterprise, HP LaserJet Managed Printers","id":"CVE-2025-26508"},"products":["Instaclustr fork of Stratio's Cassandra-Lucene-Index plugin"],"published":"2025-02-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-01-22","vendors":["NetApp"]},"summary":"Authenticated users can bypass RBAC and escalate privileges in Cassandra installations using the vulnerable Lucene Index plugin.","url":"https://insights.sbomify.com/CVE-2025-26511/"}