# CVE-2025-26511: Cassandra-Lucene-Index allows bypass of Cassandra RBAC

> Authenticated users can bypass RBAC and escalate privileges in Cassandra installations using the vulnerable Lucene Index plugin.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Feb 2025
- **Updated:** 22 Jan 2026
- **Also known as:** GHSA-mrqp-q7vx-v2cx

## What is CVE-2025-26511?

CVE-2025-26511 is a high-severity authentication bypass vulnerability in NetApp Instaclustr fork of Stratio's Cassandra-Lucene-Index plugin, published on 13 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Systems running the Instaclustr 
fork of Stratio's Cassandra-Lucene-Index plugin versions 4.0-rc1-1.0.0 
through 4.0.16-1.0.0 and 4.1.2-1.0.0 through 4.1.8-1.0.0, installed into
 Apache Cassandra version 4.x, are susceptible to a vulnerability which 
when successfully exploited could allow authenticated Cassandra users to
 remotely bypass RBAC and escalate their privileges.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-26511?

4 open source packages ship an affected version, including com.instaclustr:cassandra-lucene-index-plugin.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.instaclustr:cassandra-lucene-index-plugin` | Maven | From 4.0-rc1-1.0.0 | 4.0.17-1.0.0 |
| `com.instaclustr:cassandra-lucene-index-plugin` | Maven | From 4.0-rc1-1.0.0 | 4.0.17-1.0.0 |
| `com.instaclustr:cassandra-lucene-index-plugin` | Maven | From 4.1.0-1.0.0 | 4.1.8-1.0.1 |
| `com.instaclustr:cassandra-lucene-index-plugin` | Maven | From 4.1.0-1.0.0 | 4.1.8-1.0.1 |

## How do I fix CVE-2025-26511?

Upgrade com.instaclustr:cassandra-lucene-index-plugin to a fixed version for your release line: 4.0.17-1.0.0 or 4.1.8-1.0.1.

## Is CVE-2025-26511 being exploited?

There is no known exploitation of CVE-2025-26511 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-26511 and fix it if it is affected.

What it is: CVE-2025-26511 is a high-severity authentication bypass vulnerability in NetApp Instaclustr fork of Stratio's Cassandra-Lucene-Index plugin, published on 13 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-26511 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.instaclustr:cassandra-lucene-index-plugin (Maven): affected from 4.0-rc1-1.0.0; fixed in 4.0.17-1.0.0
- com.instaclustr:cassandra-lucene-index-plugin (Maven): affected from 4.0-rc1-1.0.0; fixed in 4.0.17-1.0.0
- com.instaclustr:cassandra-lucene-index-plugin (Maven): affected from 4.1.0-1.0.0; fixed in 4.1.8-1.0.1
- com.instaclustr:cassandra-lucene-index-plugin (Maven): affected from 4.1.0-1.0.0; fixed in 4.1.8-1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-26511/ (Markdown: https://insights.sbomify.com/CVE-2025-26511/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-26511
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-26511
- OSV: https://osv.dev/vulnerability/CVE-2025-26511

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-26511/
Summaries are generated and may contain mistakes; the official description above is the record.
