CVE-2025-26525 Arbitrary file read risk through pdfTeX
Attackers can read arbitrary files on Moodle sites with pdfTeX enabled due to insufficient sanitization in the TeX notation filter.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-26525?
CVE-2025-26525 is a high-severity path traversal vulnerability in Moodle Moodle, published on 24 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Insufficient sanitizing in the TeX notation filter resulted in an arbitrary file read risk on sites where pdfTeX is available (such as those with TeX Live installed).
Weakness: CWE-552
Which versions are affected by CVE-2025-26525?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.1.16 |
moodle/moodle Packagist | All versions | 4.1.16 |
moodle/moodle Packagist | From 4.3.0-beta | 4.3.10 |
moodle/moodle Packagist | From 4.3.0-beta | 4.3.10 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.6 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.6 |
3 more packages
moodle/moodle Packagist | From 4.5.0-beta | 4.5.2 |
moodle/moodle Packagist | From 4.5.0-beta | 4.5.2 |
moodle Bitnami | From 4.1.0 | 4.1.16, 4.3.10, 4.4.6, 4.5.2 |
Products include Moodle Moodle.
How do I fix CVE-2025-26525?
Upgrade moodle/moodle to a fixed version for your release line: 4.1.16, 4.3.10, 4.4.6 or 4.5.2.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2025-26525 being exploited?
There is no known exploitation of CVE-2025-26525 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2025-26525, GHSA-4hmr-39vp-xfrr, UBUNTU-CVE-2025-26525.