# CVE-2025-26529: Stored XSS risk in admin live log

> Attackers can inject malicious scripts into the admin live log, potentially leading to code execution or account takeover in Moodle.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Feb 2025
- **Updated:** 24 Feb 2025
- **Also known as:** BIT-moodle-2025-26529, GHSA-wr88-x8cm-7cgq, UBUNTU-CVE-2025-26529

## What is CVE-2025-26529?

CVE-2025-26529 is a high-severity cross-site scripting vulnerability in Moodle Moodle, published on 24 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Description information displayed in the site administration live log 
required additional sanitizing to prevent a stored XSS risk.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-26529?

9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | All versions | 4.1.16 |
| `moodle/moodle` | Packagist | All versions | 4.1.16 |
| `moodle/moodle` | Packagist | From 4.3.0-beta | 4.3.10 |
| `moodle/moodle` | Packagist | From 4.3.0-beta | 4.3.10 |
| `moodle/moodle` | Packagist | From 4.4.0-beta | 4.4.6 |
| `moodle/moodle` | Packagist | From 4.4.0-beta | 4.4.6 |
| `moodle/moodle` | Packagist | From 4.5.0-beta | 4.5.2 |
| `moodle/moodle` | Packagist | From 4.5.0-beta | 4.5.2 |
| `moodle` | Bitnami | From 4.1.0 | 4.1.16, 4.3.10, 4.4.6, 4.5.2 |

Products: Moodle Moodle.

## How do I fix CVE-2025-26529?

Upgrade moodle/moodle to a fixed version for your release line: 4.1.16, 4.3.10, 4.4.6 or 4.5.2.

## Is CVE-2025-26529 being exploited?

There is no known exploitation of CVE-2025-26529 in the wild and no public exploit code.

Public exploit code:

- SSRF to XSS - XSS to RCE Moodle (github_poc): https://github.com/Astroo18/PoC-CVE-2025-26529
- Web CTF challenge highlighting moodle CVE-2025-26529 (in 2 flavors) (github_poc): https://github.com/hxuu/moodle-cve

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-26529 and fix it if it is affected.

What it is: CVE-2025-26529 is a high-severity cross-site scripting vulnerability in Moodle Moodle, published on 24 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-26529 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected all versions; fixed in 4.1.16
- moodle/moodle (Packagist): affected all versions; fixed in 4.1.16
- moodle/moodle (Packagist): affected from 4.3.0-beta; fixed in 4.3.10
- moodle/moodle (Packagist): affected from 4.3.0-beta; fixed in 4.3.10
- moodle/moodle (Packagist): affected from 4.4.0-beta; fixed in 4.4.6
- moodle/moodle (Packagist): affected from 4.4.0-beta; fixed in 4.4.6
- moodle/moodle (Packagist): affected from 4.5.0-beta; fixed in 4.5.2
- moodle/moodle (Packagist): affected from 4.5.0-beta; fixed in 4.5.2
- moodle (Bitnami): affected from 4.1.0; fixed in 4.1.16, 4.3.10, 4.4.6, 4.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-26529/ (Markdown: https://insights.sbomify.com/CVE-2025-26529/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-26529
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-26529
- OSV: https://osv.dev/vulnerability/CVE-2025-26529

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-26529/
Summaries are generated and may contain mistakes; the official description above is the record.
