CVE-2025-26530 Reflected XSS via question bank filter
Attackers can execute arbitrary scripts in victim browsers via the question bank filter, potentially leading to session hijacking or data theft.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-26530?
CVE-2025-26530 is a high-severity cross-site scripting vulnerability in Moodle Moodle, published on 24 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
The question bank filter required additional sanitizing to prevent a reflected XSS risk.
Weakness: CWE-79
Which versions are affected by CVE-2025-26530?
7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 4.3.0-beta | 4.3.10 |
moodle/moodle Packagist | From 4.3.0-beta | 4.3.10 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.6 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.6 |
moodle/moodle Packagist | From 4.5.0-beta | 4.5.2 |
moodle/moodle Packagist | From 4.5.0-beta | 4.5.2 |
1 more packages
moodle Bitnami | From 4.3.0 | 4.3.10, 4.4.6, 4.5.2 |
Products include Moodle Moodle.
How do I fix CVE-2025-26530?
Upgrade moodle/moodle to a fixed version for your release line: 4.3.10, 4.4.6 or 4.5.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-26530 being exploited?
There is no known exploitation of CVE-2025-26530 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2025-26530, GHSA-4w32-c9g7-27qx, UBUNTU-CVE-2025-26530.