# CVE-2025-26531: IDOR in badges allows disabling of arbitrary badges

> Attackers can disable arbitrary badges in Moodle due to insufficient capability checks, requiring a patch to restore proper authorization controls.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Feb 2025
- **Updated:** 25 Feb 2025
- **Also known as:** BIT-moodle-2025-26531, GHSA-g88w-v4cq-qgcp, UBUNTU-CVE-2025-26531

## What is CVE-2025-26531?

CVE-2025-26531 is a low-severity missing authorization vulnerability in Moodle Moodle, published on 24 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Insufficient capability checks made it possible to disable badges a user does not have permission to access.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-26531?

9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | All versions | 4.1.16 |
| `moodle/moodle` | Packagist | All versions | 4.1.16 |
| `moodle/moodle` | Packagist | From 4.3.0-beta | 4.3.10 |
| `moodle/moodle` | Packagist | From 4.3.0-beta | 4.3.10 |
| `moodle/moodle` | Packagist | From 4.4.0-beta | 4.4.6 |
| `moodle/moodle` | Packagist | From 4.4.0-beta | 4.4.6 |
| `moodle/moodle` | Packagist | From 4.5.0-beta | 4.5.2 |
| `moodle/moodle` | Packagist | From 4.5.0-beta | 4.5.2 |
| `moodle` | Bitnami | From 4.1.0 | 4.1.16, 4.3.10, 4.4.6, 4.5.2 |

Products: Moodle Moodle.

## How do I fix CVE-2025-26531?

Upgrade moodle/moodle to a fixed version for your release line: 4.1.16, 4.3.10, 4.4.6 or 4.5.2.

## Is CVE-2025-26531 being exploited?

There is no known exploitation of CVE-2025-26531 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-26531 and fix it if it is affected.

What it is: CVE-2025-26531 is a low-severity missing authorization vulnerability in Moodle Moodle, published on 24 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-26531 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected all versions; fixed in 4.1.16
- moodle/moodle (Packagist): affected all versions; fixed in 4.1.16
- moodle/moodle (Packagist): affected from 4.3.0-beta; fixed in 4.3.10
- moodle/moodle (Packagist): affected from 4.3.0-beta; fixed in 4.3.10
- moodle/moodle (Packagist): affected from 4.4.0-beta; fixed in 4.4.6
- moodle/moodle (Packagist): affected from 4.4.0-beta; fixed in 4.4.6
- moodle/moodle (Packagist): affected from 4.5.0-beta; fixed in 4.5.2
- moodle/moodle (Packagist): affected from 4.5.0-beta; fixed in 4.5.2
- moodle (Bitnami): affected from 4.1.0; fixed in 4.1.16, 4.3.10, 4.4.6, 4.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-26531/ (Markdown: https://insights.sbomify.com/CVE-2025-26531/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-26531
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-26531
- OSV: https://osv.dev/vulnerability/CVE-2025-26531

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-26531/
Summaries are generated and may contain mistakes; the official description above is the record.
