CVE-2025-26532 Teachers can evade trusttext config when restoring glossary entries
Teachers can bypass trusttext security checks when restoring glossary entries, potentially allowing unsafe content injection.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-26532?
CVE-2025-26532 is a low-severity vulnerability in Moodle Moodle, published on 24 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Additional checks were required to ensure trusttext is applied (when enabled) to glossary entries being restored.
Weakness: CWE-863
Which versions are affected by CVE-2025-26532?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.1.16 |
moodle/moodle Packagist | All versions | 4.1.16 |
moodle/moodle Packagist | From 4.3.0-beta | 4.3.10 |
moodle/moodle Packagist | From 4.3.0-beta | 4.3.10 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.6 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.6 |
3 more packages
moodle/moodle Packagist | From 4.5.0-beta | 4.5.2 |
moodle/moodle Packagist | From 4.5.0-beta | 4.5.2 |
moodle Bitnami | From 4.1.0 | 4.1.16, 4.3.10, 4.4.6, 4.5.2 |
Products include Moodle Moodle.
How do I fix CVE-2025-26532?
Upgrade moodle/moodle to a fixed version for your release line: 4.1.16, 4.3.10, 4.4.6 or 4.5.2.
Is CVE-2025-26532 being exploited?
There is no known exploitation of CVE-2025-26532 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2025-26532, GHSA-cw24-f6fq-7j9v, UBUNTU-CVE-2025-26532.