CVE-2025-26619 Vega Cross-Site Scripting (XSS) via event filter when not using CSP mode `expressionInterpeter`
Attackers can execute arbitrary JavaScript in Vega visualizations if the default expression interpreter is used, requiring an upgrade or CSP configuration.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-26619?
CVE-2025-26619 is a medium-severity cross-site scripting vulnerability in vega, published on 27 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. In `vega` 5.30.0 and lower and in `vega-functions` 5.15.0 and lower , it was possible to call JavaScript functions from the Vega expression language that were not meant to be supported. The issue is patched in `vega` `5.31.0` and `vega-functions` `5.16.0`. Some workarounds are available. Run `vega` without `vega.expressionInterpreter`. This mode is not the default as it is slower. Alternatively, using the interpreter described in CSP safe mode (Content Security Policy) prevents arbitrary Javascript from running, so users of this mode are not affected by this vulnerability.
Weakness: CWE-79
Which versions are affected by CVE-2025-26619?
4 open source packages ship an affected version, including vega and vega-functions. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
vega npm | All versions | 5.31.0 |
vega npm | All versions | 5.31.0 |
vega-functions npm | All versions | 5.16.0 |
vega-functions npm | All versions | 5.16.0 |
Products include Vega-Functions Project Vega-Functions, Vega Project Vega.
How do I fix CVE-2025-26619?
Upgrade vega to 5.31.0 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-26619 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-26619 exists.
Other vulnerabilities in vega
Sources
Also known as DEBIAN-CVE-2025-26619, GHSA-rcw3-wmx7-cphr, UBUNTU-CVE-2025-26619.