{"answers":{"affected":"4 open source packages ship an affected version, including vega and vega-functions. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-26619 exists.","fix":"Upgrade vega to 5.31.0 or later.","what":"CVE-2025-26619 is a medium-severity cross-site scripting vulnerability in vega, published on 27 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-26619 and fix it if it is affected.\n\nWhat it is: CVE-2025-26619 is a medium-severity cross-site scripting vulnerability in vega, published on 27 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-26619 exists.\n\nAffected packages and fixed versions:\n- vega (npm): affected all versions; fixed in 5.31.0\n- vega (npm): affected all versions; fixed in 5.31.0\n- vega-functions (npm): affected all versions; fixed in 5.16.0\n- vega-functions (npm): affected all versions; fixed in 5.16.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-26619/ (Markdown: https://insights.sbomify.com/CVE-2025-26619/index.md)","id":"CVE-2025-26619","markdown":"https://insights.sbomify.com/CVE-2025-26619/index.md","name":"CVE-2025-26619","record":{"aliases":["DEBIAN-CVE-2025-26619","GHSA-rcw3-wmx7-cphr","UBUNTU-CVE-2025-26619"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Vega visualization library","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript in Vega visualizations if the default expression interpreter is used, requiring an upgrade or CSP configuration.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vega-functions","vendor":"vega-functions_project"},{"product":"vega","vendor":"vega_project"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. In `vega` 5.30.0 and lower and in `vega-functions` 5.15.0 and lower , it was possible to call JavaScript functions from the Vega expression language that were not meant to be supported. The issue is patched in `vega` `5.31.0`  and `vega-functions` `5.16.0`. Some workarounds are available. Run `vega` without `vega.expressionInterpreter`. This mode is not the default as it is slower. Alternatively, using the interpreter described in CSP safe mode (Content Security Policy) prevents arbitrary Javascript from running, so users of this mode are not affected by this vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Vega Cross-Site Scripting (XSS) via event filter when not using CSP mode `expressionInterpeter`","id":"CVE-2025-26619","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":4,"n_references":4,"next":{"headline":"Duende.AccessTokenManagement race condition when concurrently retrieving customized Client Credentials Access Tokens","id":"CVE-2025-26620"},"packages":[{"ecosystem":"npm","fixed":["5.31.0"],"introduced":["0"],"last_affected":[],"package":"vega","purl":null,"source":"GHSA-rcw3-wmx7-cphr"},{"ecosystem":"npm","fixed":["5.31.0"],"introduced":["0"],"last_affected":[],"package":"vega","purl":"pkg:npm/vega","source":"GHSA-rcw3-wmx7-cphr"},{"ecosystem":"npm","fixed":["5.16.0"],"introduced":["0"],"last_affected":[],"package":"vega-functions","purl":null,"source":"GHSA-rcw3-wmx7-cphr"},{"ecosystem":"npm","fixed":["5.16.0"],"introduced":["0"],"last_affected":[],"package":"vega-functions","purl":"pkg:npm/vega-functions","source":"GHSA-rcw3-wmx7-cphr"}],"prev":{"headline":"SSH SFTP packet size not verified properly in Erlang OTP","id":"CVE-2025-26618"},"products":["vega"],"published":"2025-03-27","related":[{"cvss_score":7.2,"headline":"`vega-functions` vulnerable to Cross-site Scripting via `setdata` function","id":"CVE-2025-66648","kev_date_added":null,"published":"2026-01-05"},{"cvss_score":6.5,"headline":"Vega `scale` expression function cross site scripting","id":"CVE-2023-26486","kev_date_added":null,"published":"2023-03-03"},{"cvss_score":6.5,"headline":"Vega has cross-site scripting vulnerability in `lassoAppend` function","id":"CVE-2023-26487","kev_date_added":null,"published":"2023-03-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-27","vendors":["vega"]},"summary":"Attackers can execute arbitrary JavaScript in Vega visualizations if the default expression interpreter is used, requiring an upgrade or CSP configuration.","url":"https://insights.sbomify.com/CVE-2025-26619/"}