# CVE-2025-26619: Vega Cross-Site Scripting (XSS) via event filter when not using CSP mode `expressionInterpeter`

> Attackers can execute arbitrary JavaScript in Vega visualizations if the default expression interpreter is used, requiring an upgrade or CSP configuration.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Mar 2025
- **Updated:** 27 Mar 2025
- **Also known as:** DEBIAN-CVE-2025-26619, GHSA-rcw3-wmx7-cphr, UBUNTU-CVE-2025-26619

## What is CVE-2025-26619?

CVE-2025-26619 is a medium-severity cross-site scripting vulnerability in vega, published on 27 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. In `vega` 5.30.0 and lower and in `vega-functions` 5.15.0 and lower , it was possible to call JavaScript functions from the Vega expression language that were not meant to be supported. The issue is patched in `vega` `5.31.0`  and `vega-functions` `5.16.0`. Some workarounds are available. Run `vega` without `vega.expressionInterpreter`. This mode is not the default as it is slower. Alternatively, using the interpreter described in CSP safe mode (Content Security Policy) prevents arbitrary Javascript from running, so users of this mode are not affected by this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-26619?

4 open source packages ship an affected version, including vega and vega-functions. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vega` | npm | All versions | 5.31.0 |
| `vega` | npm | All versions | 5.31.0 |
| `vega-functions` | npm | All versions | 5.16.0 |
| `vega-functions` | npm | All versions | 5.16.0 |

Products: Vega-Functions Project Vega-Functions, Vega Project Vega.

## How do I fix CVE-2025-26619?

Upgrade vega to 5.31.0 or later.

## Is CVE-2025-26619 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-26619 exists.

## Other vulnerabilities in vega

- [CVE-2025-66648](https://insights.sbomify.com/CVE-2025-66648/): `vega-functions` vulnerable to Cross-site Scripting via `setdata` function (high 7.2)
- [CVE-2023-26486](https://insights.sbomify.com/CVE-2023-26486/): Vega `scale` expression function cross site scripting (medium 6.5)
- [CVE-2023-26487](https://insights.sbomify.com/CVE-2023-26487/): Vega has cross-site scripting vulnerability in `lassoAppend` function (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-26619 and fix it if it is affected.

What it is: CVE-2025-26619 is a medium-severity cross-site scripting vulnerability in vega, published on 27 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-26619 exists.

Affected packages and fixed versions:
- vega (npm): affected all versions; fixed in 5.31.0
- vega (npm): affected all versions; fixed in 5.31.0
- vega-functions (npm): affected all versions; fixed in 5.16.0
- vega-functions (npm): affected all versions; fixed in 5.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-26619/ (Markdown: https://insights.sbomify.com/CVE-2025-26619/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-26619
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-26619
- OSV: https://osv.dev/vulnerability/CVE-2025-26619

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-26619/
Summaries are generated and may contain mistakes; the official description above is the record.
