# CVE-2025-26621: OpenCTI vulnerable to Denial of Service through web hook

> Users with customization rights can inject JavaScript via webhooks to cause denial of service or execute code in OpenCTI.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 May 2025
- **Updated:** 19 May 2025
- **Also known as:** PYSEC-2025-180

## What is CVE-2025-26621?

CVE-2025-26621 is a high-severity code injection vulnerability in OpenCTI-Platform opencti, published on 19 May 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

OpenCTI is an open source platform for managing cyber threat intelligence knowledge and observables. Prior to version 6.5.2, any user with the capability manage customizations can edit webhook that will execute javascript code. This can be abused to cause a denial of service attack by prototype pollution, making the node js server running the OpenCTI frontend become unavailable. Version 6.5.2 fixes the issue.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-26621?

1 open source package ship an affected version, including pycti. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pycti` | PyPI | All versions | 6.5.2 |

Products: Citeum Opencti.

## How do I fix CVE-2025-26621?

Upgrade pycti to 6.5.2 or later.

## Is CVE-2025-26621 being exploited?

There is no known exploitation of CVE-2025-26621 in the wild and no public exploit code.

## Other vulnerabilities in OpenCTI-Platform opencti

- [CVE-2026-27960](https://insights.sbomify.com/CVE-2026-27960/): OpenCTI privilege escalation and unauthenticated access via default admin account (critical 9.8)
- [CVE-2026-39980](https://insights.sbomify.com/CVE-2026-39980/): OpenCTI affected by RCE via notifier template (critical 9.1)
- [CVE-2025-24977](https://insights.sbomify.com/CVE-2025-24977/): OpenCTI has remote code execution and sensitive secrets exposed through web hook (critical 9.1)
- [CVE-2024-26139](https://insights.sbomify.com/CVE-2024-26139/): OpenCTI Authenticated Privilege Escalation (high 8.3)
- [CVE-2024-45404](https://insights.sbomify.com/CVE-2024-45404/): OpenCTI's lack of Rate Limit lead to OTP brute forcing (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-26621 and fix it if it is affected.

What it is: CVE-2025-26621 is a high-severity code injection vulnerability in OpenCTI-Platform opencti, published on 19 May 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-26621 in the wild and no public exploit code.

Affected packages and fixed versions:
- pycti (PyPI): affected all versions; fixed in 6.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-26621/ (Markdown: https://insights.sbomify.com/CVE-2025-26621/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-26621
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-26621
- OSV: https://osv.dev/vulnerability/CVE-2025-26621

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-26621/
Summaries are generated and may contain mistakes; the official description above is the record.
