# CVE-2025-26622: sqrt doesn't define rounding behavior in Vyper

> The Vyper compiler's sqrt function may return incorrectly rounded results, potentially affecting smart contract logic accuracy.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Feb 2025
- **Updated:** 22 Feb 2025
- **Also known as:** GHSA-2p94-8669-xg86, PYSEC-2025-29

## What is CVE-2025-26622?

CVE-2025-26622 is a low-severity vulnerability in vyperlang vyper, published on 21 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vyper is a Pythonic Smart Contract Language for the EVM. Vyper `sqrt()` builtin uses the babylonian method to calculate square roots of decimals. Unfortunately, improper handling of the oscillating final states may lead to sqrt incorrectly returning rounded up results. This issue is being addressed and a fix is expected in version 0.4.1. Users are advised to upgrade as soon as the patched release is available. There are no known workarounds for this vulnerability.

Weakness: CWE-682 (Incorrect Calculation)

## Which versions are affected by CVE-2025-26622?

3 open source packages ship an affected version, including vyper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vyper` | PyPI | All versions | 0.4.1 |
| `vyper` | PyPI | All versions | 0.4.1 |
| `vyper` | PyPI | All versions | 0.4.1 |

Products: Vyperlang Vyper.

## How do I fix CVE-2025-26622?

Upgrade vyper to 0.4.1 or later.

## Is CVE-2025-26622 being exploited?

There is no known exploitation of CVE-2025-26622 in the wild and no public exploit code.

## Other vulnerabilities in vyperlang vyper

- [CVE-2024-24563](https://insights.sbomify.com/CVE-2024-24563/): Vyper array negative index vulnerability (critical 9.8)
- [CVE-2024-24561](https://insights.sbomify.com/CVE-2024-24561/): Vyper bounds check on built-in `slice()` function can be overflowed (critical 9.8)
- [CVE-2023-39363](https://insights.sbomify.com/CVE-2023-39363/): Vyper incorrectly allocated named re-entrancy locks (critical 9.1)
- [CVE-2022-24845](https://insights.sbomify.com/CVE-2022-24845/): Integer bounds error in Vyper (high 8.8)
- [CVE-2022-29255](https://insights.sbomify.com/CVE-2022-29255/): Multiple evaluation of contract address in call in vyper (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-26622 and fix it if it is affected.

What it is: CVE-2025-26622 is a low-severity vulnerability in vyperlang vyper, published on 21 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-26622 in the wild and no public exploit code.

Affected packages and fixed versions:
- vyper (PyPI): affected all versions; fixed in 0.4.1
- vyper (PyPI): affected all versions; fixed in 0.4.1
- vyper (PyPI): affected all versions; fixed in 0.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-26622/ (Markdown: https://insights.sbomify.com/CVE-2025-26622/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-26622
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-26622
- OSV: https://osv.dev/vulnerability/CVE-2025-26622

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-26622/
Summaries are generated and may contain mistakes; the official description above is the record.
