CVE-2025-26623 Use After Free in Exiv2
Attacker can execute code by tricking users into writing metadata to a crafted image file using the Exiv2 library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-26623?
CVE-2025-26623 is a medium-severity use after free vulnerability in Exiv2 Exiv2, published on 18 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Exiv2 is a C++ library and a command-line utility to read, write, delete and modify Exif, IPTC, XMP and ICC image metadata. A heap buffer overflow was found in Exiv2 versions v0.28.0 to v0.28.4. Versions prior to v0.28.0, such as v0.27.7, are **not** affected. Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. The heap overflow is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to gain code execution, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when writing the metadata, which is a less frequently used Exiv2 operation than reading the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as `fixiso`. The bug is fixed in version v0.28.5. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Weakness: CWE-416
Which versions are affected by CVE-2025-26623?
3 open source packages ship an affected version, including exiv2 and Exiv2. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
exiv2 PyPI | From 0.28.0 | 0.28.5 |
exiv2 PyPI | From 0.28.0 | 0.28.5 |
Exiv2 PyPI | From 0.28.0 | 0.28.5 |
Linux distribution packages (12)
exiv2 AlmaLinux:10 | All versions | 0.28.3-3.el10_0.2 |
exiv2-devel AlmaLinux:10 | All versions | 0.28.3-3.el10_0.2 |
exiv2-doc AlmaLinux:10 | All versions | 0.28.3-3.el10_0.2 |
exiv2-libs AlmaLinux:10 | All versions | 0.28.3-3.el10_0.2 |
exiv2 Red Hat:enterprise_linux:10.0 | All versions | 0:0.28.3-3.el10_0.2 |
exiv2-debuginfo Red Hat:enterprise_linux:10.0 | All versions | 0:0.28.3-3.el10_0.2 |
exiv2-debugsource Red Hat:enterprise_linux:10.0 | All versions | 0:0.28.3-3.el10_0.2 |
exiv2-devel Red Hat:enterprise_linux:10.0 | All versions | 0:0.28.3-3.el10_0.2 |
exiv2-doc Red Hat:enterprise_linux:10.0 | All versions | 0:0.28.3-3.el10_0.2 |
exiv2-libs Red Hat:enterprise_linux:10.0 | All versions | 0:0.28.3-3.el10_0.2 |
exiv2-libs-debuginfo Red Hat:enterprise_linux:10.0 | All versions | 0:0.28.3-3.el10_0.2 |
exiv2 Rocky Linux:10 | All versions | 0:0.28.3-3.el10_0.2 |
Products include Exiv2 Exiv2.
How do I fix CVE-2025-26623?
Upgrade exiv2 to 0.28.5 or later.
Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.
Is CVE-2025-26623 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-26623 exists.
Other vulnerabilities in Exiv2 Exiv2
Sources
Also known as ALSA-2025:7457, AZL-56946, AZL-57071, DEBIAN-CVE-2025-26623, GHSA-38h4-fx85-qcx7, OESA-2025-1197 and 4 more.