# CVE-2025-26623: Use After Free in Exiv2

> Attacker can execute code by tricking users into writing metadata to a crafted image file using the Exiv2 library.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Feb 2025
- **Updated:** 19 Feb 2025
- **Also known as:** ALSA-2025:7457, AZL-56946, AZL-57071, DEBIAN-CVE-2025-26623, GHSA-38h4-fx85-qcx7, OESA-2025-1197, OESA-2025-1198, PYSEC-2026-1353, RHSA-2025:7457, RLSA-2025:7457

## What is CVE-2025-26623?

CVE-2025-26623 is a medium-severity use after free vulnerability in Exiv2 Exiv2, published on 18 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Exiv2 is a C++ library and a command-line utility to read, write, delete and modify Exif, IPTC, XMP and ICC image metadata. A heap buffer overflow was found in Exiv2 versions v0.28.0 to v0.28.4. Versions prior to v0.28.0, such as v0.27.7, are **not** affected. Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. The heap overflow is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to gain code execution, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when writing the metadata, which is a less frequently used Exiv2 operation than reading the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as `fixiso`. The bug is fixed in version v0.28.5. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2025-26623?

3 open source packages ship an affected version, including exiv2 and Exiv2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `exiv2` | PyPI | From 0.28.0 | 0.28.5 |
| `exiv2` | PyPI | From 0.28.0 | 0.28.5 |
| `Exiv2` | PyPI | From 0.28.0 | 0.28.5 |
| `exiv2` | AlmaLinux:10 | All versions | 0.28.3-3.el10_0.2 |
| `exiv2-devel` | AlmaLinux:10 | All versions | 0.28.3-3.el10_0.2 |
| `exiv2-doc` | AlmaLinux:10 | All versions | 0.28.3-3.el10_0.2 |
| `exiv2-libs` | AlmaLinux:10 | All versions | 0.28.3-3.el10_0.2 |
| `exiv2` | Red Hat:enterprise_linux:10.0 | All versions | 0:0.28.3-3.el10_0.2 |
| `exiv2-debuginfo` | Red Hat:enterprise_linux:10.0 | All versions | 0:0.28.3-3.el10_0.2 |
| `exiv2-debugsource` | Red Hat:enterprise_linux:10.0 | All versions | 0:0.28.3-3.el10_0.2 |
| `exiv2-devel` | Red Hat:enterprise_linux:10.0 | All versions | 0:0.28.3-3.el10_0.2 |
| `exiv2-doc` | Red Hat:enterprise_linux:10.0 | All versions | 0:0.28.3-3.el10_0.2 |
| `exiv2-libs` | Red Hat:enterprise_linux:10.0 | All versions | 0:0.28.3-3.el10_0.2 |
| `exiv2-libs-debuginfo` | Red Hat:enterprise_linux:10.0 | All versions | 0:0.28.3-3.el10_0.2 |
| `exiv2` | Rocky Linux:10 | All versions | 0:0.28.3-3.el10_0.2 |

Products: Exiv2 Exiv2.

## How do I fix CVE-2025-26623?

Upgrade exiv2 to 0.28.5 or later.

## Is CVE-2025-26623 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-26623 exists.

## Other vulnerabilities in Exiv2 Exiv2

- [CVE-2023-44398](https://insights.sbomify.com/CVE-2023-44398/): Out-of-bounds write in exiv2 (high 8.8)
- [CVE-2019-9143](https://insights.sbomify.com/CVE-2019-9143/): Denial of service in n/a (high 8.8)
- [CVE-2019-9144](https://insights.sbomify.com/CVE-2019-9144/): Denial of service in n/a (high 8.8)
- [CVE-2018-14046](https://insights.sbomify.com/CVE-2018-14046/): Memory corruption in n/a (high 8.8)
- [CVE-2017-12955](https://insights.sbomify.com/CVE-2017-12955/): Memory corruption in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-26623 and fix it if it is affected.

What it is: CVE-2025-26623 is a medium-severity use after free vulnerability in Exiv2 Exiv2, published on 18 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-26623 exists.

Affected packages and fixed versions:
- exiv2 (PyPI): affected from 0.28.0; fixed in 0.28.5
- exiv2 (PyPI): affected from 0.28.0; fixed in 0.28.5
- Exiv2 (PyPI): affected from 0.28.0; fixed in 0.28.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-26623/ (Markdown: https://insights.sbomify.com/CVE-2025-26623/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-26623
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-26623
- OSV: https://osv.dev/vulnerability/CVE-2025-26623

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-26623/
Summaries are generated and may contain mistakes; the official description above is the record.
