CVE-2025-26699 Django vulnerable to Allocation of Resources Without Limits or Throttling
Attackers can cause denial of service in Django applications by exploiting the text wrap utility with very long strings.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-26699?
CVE-2025-26699 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 6 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered in Django 5.1 before 5.1.7, 5.0 before 5.0.13, and 4.2 before 4.2.20. The django.utils.text.wrap() method and wordwrap template filter are subject to a potential denial-of-service attack when used with very long strings.
Weakness: CWE-770
Which versions are affected by CVE-2025-26699?
8 open source packages ship an affected version, including django and Django. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
django Bitnami | From 4.2.0 | 5.1.7 |
django PyPI | From 4.2 | 4.2.20 |
django PyPI | From 5.0 | 5.0.13 |
django PyPI | From 5.1 | 5.1.7, 5.0.13, 4.2.20 |
django PyPI | From 5.1 | 5.1.7 |
Django PyPI | From 4.2 | 4.2.20 |
2 more packages
Django PyPI | From 5.0 | 5.0.13 |
Django PyPI | From 5.1 | 5.1.7 |
Linux distribution packages (10)
python39-django Red Hat:ansible_automation_platform:2.4::el8 | All versions | 0:4.2.21-1.el8ap |
python3x-django Red Hat:ansible_automation_platform:2.4::el8 | All versions | 0:4.2.21-1.el8ap |
python-django Red Hat:ansible_automation_platform:2.4::el9 | All versions | 0:4.2.21-1.el9ap |
python3-django Red Hat:ansible_automation_platform:2.4::el9 | All versions | 0:4.2.21-1.el9ap |
automation-controller-venv-tower Red Hat:ansible_automation_platform:2.5::el8 | All versions | 0:4.6.12-1.el8ap |
automation-controller-venv-tower Red Hat:ansible_automation_platform:2.5::el9 | All versions | 0:4.6.12-1.el9ap |
python-Django SUSE:Linux Enterprise Module for Package Hub 15 SP6 | All versions | 4.2.11-150600.3.18.1 |
python-Django openSUSE:Leap 15.6 | All versions | 4.2.11-150600.3.18.1 |
python-Django openSUSE:Tumbleweed | All versions | 5.1.7-1.1 |
python-Django4 openSUSE:Tumbleweed | All versions | 4.2.20-1.1 |
Products include Debian Debian Linux, Djangoproject Django.
How do I fix CVE-2025-26699?
Upgrade django to a fixed version for your release line: 5.1.7, 4.2.20 or 5.0.13.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-26699 being exploited?
There is no known exploitation of CVE-2025-26699 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-django-2025-26699, DEBIAN-CVE-2025-26699, DLA-4086-1, GHSA-p3fp-8748-vqfq, MGASA-2025-0095, OESA-2025-1260 and 8 more.