# CVE-2025-26701: Hardcoded credentials in Monitoring and Management

> Default service account credentials in Percona PMM Server allow SSH access, root privilege escalation, and sensitive data exposure.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 11 Mar 2025
- **Updated:** 11 Mar 2025
- **Also known as:** GHSA-88vw-ggf5-3p2w

## What is CVE-2025-26701?

CVE-2025-26701 is a critical vulnerability in Percona Monitoring and Management, published on 11 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Percona PMM Server (OVA) before 3.0.0-1.ova. The default service account credentials can lead to SSH access, use of Sudo to root, and sensitive data exposure. This is fixed in PMM2 2.42.0-1.ova, 2.43.0-1.ova, 2.43.1-1.ova, 2.43.2-1.ova, and 2.44.0-1.ova and in PMM3 3.0.0-1.ova and later.

Weakness: CWE-1393 (Use of Default Password)

## Which versions are affected by CVE-2025-26701?


## How do I fix CVE-2025-26701?

No fix has been published for CVE-2025-26701 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-26701 being exploited?

There is no known exploitation of CVE-2025-26701 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-26701 and fix it if it is affected.

What it is: CVE-2025-26701 is a critical vulnerability in Percona Monitoring and Management, published on 11 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-26701 in the wild and no public exploit code.

Affected product: Percona Monitoring and Management. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-26701/ (Markdown: https://insights.sbomify.com/CVE-2025-26701/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-26701
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-26701
- OSV: https://osv.dev/vulnerability/CVE-2025-26701

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-26701/
Summaries are generated and may contain mistakes; the official description above is the record.
