# CVE-2025-26791: DOMPurify allows Cross-site Scripting (XSS)

> An attacker can execute arbitrary JavaScript via mutation XSS due to a flawed regex in DOMPurify, affecting applications using this library.

- **Severity:** Medium 4.5 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Feb 2025
- **Updated:** 14 Feb 2025
- **Also known as:** CLSA-2026-1774398078, CLSA-2026-1778201083, DEBIAN-CVE-2025-26791, GHSA-vhxf-7vqr-mrjg, ROOT-APP-NPM-CVE-2025-26791, UBUNTU-CVE-2025-26791, openSUSE-SU-2025:14921-1

## What is CVE-2025-26791?

CVE-2025-26791 is a medium-severity cross-site scripting vulnerability in Cure53 DOMPurify, published on 14 Feb 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

DOMPurify before 3.2.4 has an incorrect template literal regular expression, sometimes leading to mutation cross-site scripting (mXSS).

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-26791?

2 open source packages ship an affected version, including dompurify. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dompurify` | npm | All versions | 3.2.4 |
| `dompurify` | npm | All versions | 3.2.4 |
| `argocd-cli` | openSUSE:Tumbleweed | All versions | 2.14.8-1.1 |

Products: Cure53 Dompurify.

## How do I fix CVE-2025-26791?

Upgrade dompurify to 3.2.4 or later.

## Is CVE-2025-26791 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-26791 exists.

## Other vulnerabilities in Cure53 DOMPurify

- [CVE-2024-47875](https://insights.sbomify.com/CVE-2024-47875/): DOMPurify nesting-based mXSS (critical 10.0)
- [CVE-2024-48910](https://insights.sbomify.com/CVE-2024-48910/): DOMPurify vulnerable to tampering by prototype polution (critical 9.1)
- [CVE-2026-47423](https://insights.sbomify.com/CVE-2026-47423/): DOMPurify XSS via `selectedcontent` re-clone (high 8.2)
- [CVE-2024-45801](https://insights.sbomify.com/CVE-2024-45801/): Tampering by prototype polution in DOMPurify (high 7.3)
- [CVE-2026-49978](https://insights.sbomify.com/CVE-2026-49978/): DOMPurify IN_PLACE Sanitization Bypass via Attached Shadow Root Inside <template>.content (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-26791 and fix it if it is affected.

What it is: CVE-2025-26791 is a medium-severity cross-site scripting vulnerability in Cure53 DOMPurify, published on 14 Feb 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-26791 exists.

Affected packages and fixed versions:
- dompurify (npm): affected all versions; fixed in 3.2.4
- dompurify (npm): affected all versions; fixed in 3.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-26791/ (Markdown: https://insights.sbomify.com/CVE-2025-26791/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-26791
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-26791
- OSV: https://osv.dev/vulnerability/CVE-2025-26791

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-26791/
Summaries are generated and may contain mistakes; the official description above is the record.
