CVE-2025-26795 Apache IoTDB JDBC driver: Exposure of Sensitive Information in IoTDB JDBC driver

High 7.5 Published Updated

An attacker can access sensitive information exposed in log files by the Apache IoTDB JDBC driver, requiring an upgrade to secure the application.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-26795?

CVE-2025-26795 is a high-severity vulnerability in Apache IoTDB JDBC driver, published on 14 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Exposure of Sensitive Information to an Unauthorized Actor, Insertion of Sensitive Information into Log File vulnerability in Apache IoTDB JDBC driver.

This issue affects iotdb-jdbc: from 0.10.0 through 1.3.3, from 2.0.1-beta before 2.0.2.

Users are recommended to upgrade to version 2.0.2 and 1.3.4, which fix the issue.

Weakness: CWE-532, CWE-200

Which versions are affected by CVE-2025-26795?

4 open source packages ship an affected version, including org.apache.iotdb:iotdb-jdbc. It affects 1 product.

PackageAffectedFixed in
org.apache.iotdb:iotdb-jdbc MavenFrom 0.10.01.3.4
org.apache.iotdb:iotdb-jdbc MavenFrom 0.10.01.3.4
org.apache.iotdb:iotdb-jdbc MavenFrom 2.0.1-beta2.0.2
org.apache.iotdb:iotdb-jdbc MavenFrom 2.0.1-beta2.0.2

Products include Apache Iotdb.

How do I fix CVE-2025-26795?

Upgrade org.apache.iotdb:iotdb-jdbc to a fixed version for your release line: 1.3.4 or 2.0.2.

Is CVE-2025-26795 being exploited?

There is no known exploitation of CVE-2025-26795 in the wild and no public exploit code.

Sources

Also known as GHSA-gp98-hfvm-2r4x.

Is CVE-2025-26795 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free