{"answers":{"affected":"5 open source packages ship an affected version, including passenger, passenger-apache-module and passenger-nginx-module. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-26803 in the wild and no public exploit code.","fix":"Upgrade passenger to 6.0.26 or later.","what":"CVE-2025-26803 is a medium-severity denial of service vulnerability in Phusion Passenger, published on 24 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-26803 and fix it if it is affected.\n\nWhat it is: CVE-2025-26803 is a medium-severity denial of service vulnerability in Phusion Passenger, published on 24 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-26803 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- passenger (Bitnami): affected from 6.0.21; fixed in 6.0.26\n- passenger (RubyGems): affected from 6.0.21; fixed in 6.0.26\n- passenger (RubyGems): affected from 6.0.21; fixed in 6.0.26\n- passenger-apache-module (Bitnami): affected from 6.0.21; fixed in 6.0.26\n- passenger-nginx-module (Bitnami): affected from 6.0.21; fixed in 6.0.26\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-26803/ (Markdown: https://insights.sbomify.com/CVE-2025-26803/index.md)","id":"CVE-2025-26803","markdown":"https://insights.sbomify.com/CVE-2025-26803/index.md","name":"CVE-2025-26803","record":{"aliases":["BIT-passenger-2025-26803","BIT-passenger-apache-module-2025-26803","BIT-passenger-nginx-module-2025-26803","DEBIAN-CVE-2025-26803","GHSA-2cj2-qqxj-5m3r","UBUNTU-CVE-2025-26803"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Passenger application server","requires_auth":"none","summary":"An attacker can cause a denial of service in Phusion Passenger by sending a request with an invalid HTTP method.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"passenger","vendor":"phusion"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-908","name":"Use of Uninitialized Resource"}],"description":"The http parser in Phusion Passenger 6.0.21 through 6.0.25 before 6.0.26 allows a denial of service during parsing of a request with an invalid HTTP method.","ecosystems":["Bitnami","RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Phusion Passenger denial of service","id":"CVE-2025-26803","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":5,"n_references":5,"next":{"headline":"Information disclosure in n/a","id":"CVE-2025-26816"},"packages":[{"ecosystem":"Bitnami","fixed":["6.0.26"],"introduced":["6.0.21"],"last_affected":[],"package":"passenger","purl":"pkg:bitnami/passenger","source":"BIT-passenger-2025-26803"},{"ecosystem":"Bitnami","fixed":["6.0.26"],"introduced":["6.0.21"],"last_affected":[],"package":"passenger-apache-module","purl":"pkg:bitnami/passenger-apache-module","source":"BIT-passenger-apache-module-2025-26803"},{"ecosystem":"Bitnami","fixed":["6.0.26"],"introduced":["6.0.21"],"last_affected":[],"package":"passenger-nginx-module","purl":"pkg:bitnami/passenger-nginx-module","source":"BIT-passenger-nginx-module-2025-26803"},{"ecosystem":"RubyGems","fixed":["6.0.26"],"introduced":["6.0.21"],"last_affected":[],"package":"passenger","purl":null,"source":"GHSA-2cj2-qqxj-5m3r"},{"ecosystem":"RubyGems","fixed":["6.0.26"],"introduced":["6.0.21"],"last_affected":[],"package":"passenger","purl":"pkg:gem/passenger","source":"GHSA-2cj2-qqxj-5m3r"}],"prev":{"headline":"Apache Oozie: XSS in Oozie Web Console","id":"CVE-2025-26796"},"products":["Passenger"],"published":"2025-02-24","related":[{"cvss_score":9.8,"headline":"Phusion Passenger SpawningKit Contains Arbitrary Read/Write Vulnerability","id":"CVE-2018-12026","kev_date_added":null,"published":"2018-06-17"},{"cvss_score":8.8,"headline":"Insecure Permissions in Phusion Passenger","id":"CVE-2018-12027","kev_date_added":null,"published":"2018-06-17"},{"cvss_score":7.8,"headline":"Incorrect Access Control in Phusion Passenger","id":"CVE-2018-12028","kev_date_added":null,"published":"2018-06-17"},{"cvss_score":7.8,"headline":"Phusion Passenger uses a known /tmp filename","id":"CVE-2016-10345","kev_date_added":null,"published":"2017-04-18"},{"cvss_score":7.5,"headline":"RubyGems passenger gem allows remote attackers to delete files","id":"CVE-2012-6135","kev_date_added":null,"published":"2019-11-19"},{"cvss_score":5.3,"headline":"Phusion Passenger incorrect permission assignment","id":"CVE-2018-12615","kev_date_added":null,"published":"2018-06-21"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-24","vendors":["Phusion"]},"summary":"An attacker can cause a denial of service in Phusion Passenger by sending a request with an invalid HTTP method.","url":"https://insights.sbomify.com/CVE-2025-26803/"}