# CVE-2025-26803: Phusion Passenger denial of service

> An attacker can cause a denial of service in Phusion Passenger by sending a request with an invalid HTTP method.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2025
- **Updated:** 24 Feb 2025
- **Also known as:** BIT-passenger-2025-26803, BIT-passenger-apache-module-2025-26803, BIT-passenger-nginx-module-2025-26803, DEBIAN-CVE-2025-26803, GHSA-2cj2-qqxj-5m3r, UBUNTU-CVE-2025-26803

## What is CVE-2025-26803?

CVE-2025-26803 is a medium-severity denial of service vulnerability in Phusion Passenger, published on 24 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The http parser in Phusion Passenger 6.0.21 through 6.0.25 before 6.0.26 allows a denial of service during parsing of a request with an invalid HTTP method.

Weakness: CWE-908 (Use of Uninitialized Resource)

## Which versions are affected by CVE-2025-26803?

5 open source packages ship an affected version, including passenger, passenger-apache-module and passenger-nginx-module. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `passenger` | Bitnami | From 6.0.21 | 6.0.26 |
| `passenger` | RubyGems | From 6.0.21 | 6.0.26 |
| `passenger` | RubyGems | From 6.0.21 | 6.0.26 |
| `passenger-apache-module` | Bitnami | From 6.0.21 | 6.0.26 |
| `passenger-nginx-module` | Bitnami | From 6.0.21 | 6.0.26 |

Products: Phusion Passenger.

## How do I fix CVE-2025-26803?

Upgrade passenger to 6.0.26 or later.

## Is CVE-2025-26803 being exploited?

There is no known exploitation of CVE-2025-26803 in the wild and no public exploit code.

## Other vulnerabilities in Phusion Passenger

- [CVE-2018-12026](https://insights.sbomify.com/CVE-2018-12026/): Phusion Passenger SpawningKit Contains Arbitrary Read/Write Vulnerability (critical 9.8)
- [CVE-2018-12027](https://insights.sbomify.com/CVE-2018-12027/): Insecure Permissions in Phusion Passenger (high 8.8)
- [CVE-2018-12028](https://insights.sbomify.com/CVE-2018-12028/): Incorrect Access Control in Phusion Passenger (high 7.8)
- [CVE-2016-10345](https://insights.sbomify.com/CVE-2016-10345/): Phusion Passenger uses a known /tmp filename (high 7.8)
- [CVE-2012-6135](https://insights.sbomify.com/CVE-2012-6135/): RubyGems passenger gem allows remote attackers to delete files (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-26803 and fix it if it is affected.

What it is: CVE-2025-26803 is a medium-severity denial of service vulnerability in Phusion Passenger, published on 24 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-26803 in the wild and no public exploit code.

Affected packages and fixed versions:
- passenger (Bitnami): affected from 6.0.21; fixed in 6.0.26
- passenger (RubyGems): affected from 6.0.21; fixed in 6.0.26
- passenger (RubyGems): affected from 6.0.21; fixed in 6.0.26
- passenger-apache-module (Bitnami): affected from 6.0.21; fixed in 6.0.26
- passenger-nginx-module (Bitnami): affected from 6.0.21; fixed in 6.0.26

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-26803/ (Markdown: https://insights.sbomify.com/CVE-2025-26803/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-26803
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-26803
- OSV: https://osv.dev/vulnerability/CVE-2025-26803

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-26803/
Summaries are generated and may contain mistakes; the official description above is the record.
