# CVE-2025-26852: SQL injection in Infocad FM

> Attackers can execute arbitrary SQL commands in DESCOR INFOCAD, potentially reading or modifying database contents.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 20 Mar 2025
- **Updated:** 3 Apr 2025
- **Also known as:** GHSA-8wwq-574q-q2j9

## What is CVE-2025-26852?

CVE-2025-26852 is a critical SQL injection vulnerability in Descor Infocad FM, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

DESCOR INFOCAD 3.5.1 and before and fixed in v.3.5.2.0 allows SQL Injection.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-26852?

It affects 1 product.


Products: Descor Infocad.

## How do I fix CVE-2025-26852?

No fix has been published for CVE-2025-26852 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-26852 being exploited?

There is no known exploitation of CVE-2025-26852 in the wild and no public exploit code.

## Other vulnerabilities in Descor Infocad FM

- [CVE-2025-26853](https://insights.sbomify.com/CVE-2025-26853/): Missing authorization in Infocad FM (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-26852 and fix it if it is affected.

What it is: CVE-2025-26852 is a critical SQL injection vulnerability in Descor Infocad FM, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-26852 in the wild and no public exploit code.

Affected product: Descor Infocad FM. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-26852/ (Markdown: https://insights.sbomify.com/CVE-2025-26852/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-26852
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-26852
- OSV: https://osv.dev/vulnerability/CVE-2025-26852

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-26852/
Summaries are generated and may contain mistakes; the official description above is the record.
