CVE-2025-26864 Apache IoTDB: Exposure of Sensitive Information in IoTDB OpenID Authentication
Attackers can access sensitive information exposed in log files by the OpenID authentication component of Apache IoTDB.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-26864?
CVE-2025-26864 is a high-severity vulnerability in Apache IoTDB, published on 14 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Exposure of Sensitive Information to an Unauthorized Actor, Insertion of Sensitive Information into Log File vulnerability in the OpenIdAuthorizer of Apache IoTDB.
This issue affects Apache IoTDB: from 0.10.0 through 1.3.3, from 2.0.1-beta before 2.0.2.
Users are recommended to upgrade to version 1.3.4 and 2.0.2, which fix the issue.
Which versions are affected by CVE-2025-26864?
9 open source packages ship an affected version, including apache-iotdb and org.apache.iotdb:node-commons. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache-iotdb PyPI | From 0.10.0 | 1.3.4 |
apache-iotdb PyPI | From 0.10.0 | 1.3.4 |
apache-iotdb PyPI | From 0.10.0 | 1.3.4 |
apache-iotdb PyPI | From 2.0.1b0 | 2.0.2 |
apache-iotdb PyPI | From 2.0.1b0 | 2.0.2 |
org.apache.iotdb:node-commons Maven | From 0.10.0 | 1.3.4 |
3 more packages
org.apache.iotdb:node-commons Maven | From 0.10.0 | 1.3.4 |
org.apache.iotdb:node-commons Maven | From 2.0.1-beta | 2.0.2 |
org.apache.iotdb:node-commons Maven | From 2.0.1-beta | 2.0.2 |
Products include Apache Iotdb.
How do I fix CVE-2025-26864?
Upgrade apache-iotdb to a fixed version for your release line: 1.3.4 or 2.0.2.
Is CVE-2025-26864 being exploited?
There is no known exploitation of CVE-2025-26864 in the wild and no public exploit code.
Other vulnerabilities in Apache IoTDB
- CVE-2026-24014 Apache IoTDB: Path Traversal in DataNode Internal RPC Trigger JAR Upload Allows Arbitrary File Write
- CVE-2026-24015 Apache IoTDB: Insecure Default Configuration Vulnerability
- CVE-2026-24713 Apache IoTDB: JEXL Expression Injection Vulnerability
- CVE-2024-24780 Apache IoTDB: Remote Code Execution with untrusted URI of User-defined function
- CVE-2023-46226 Apache IoTDB: Remote Code Execution (RCE) risk via the UDF
Sources
Also known as GHSA-5fc3-pqf2-57cx, PYSEC-2025-60.