# CVE-2025-2691: nossrf Server-Side Request Forgery (SSRF)

> An attacker can bypass SSRF protections in the nossrf library by using hostnames that resolve to local or reserved IP addresses.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Mar 2025
- **Updated:** 3 Aug 2026
- **Also known as:** GHSA-vm77-mr48-27wj

## What is CVE-2025-2691?

CVE-2025-2691 is a high-severity server-side request forgery vulnerability in nossrf, published on 23 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package nossrf before 1.0.4 are vulnerable to Server-Side Request Forgery (SSRF) where an attacker can provide a hostname that resolves to a local or reserved IP address space and bypass the SSRF protection mechanism.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-2691?

2 open source packages ship an affected version, including nossrf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nossrf` | npm | All versions | 1.0.4 |
| `nossrf` | npm | All versions | 1.0.4 |

Products: Nossrf Project Nossrf.

## How do I fix CVE-2025-2691?

Upgrade nossrf to 1.0.4 or later.

## Is CVE-2025-2691 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-2691 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-2691 and fix it if it is affected.

What it is: CVE-2025-2691 is a high-severity server-side request forgery vulnerability in nossrf, published on 23 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-2691 exists.

Affected packages and fixed versions:
- nossrf (npm): affected all versions; fixed in 1.0.4
- nossrf (npm): affected all versions; fixed in 1.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-2691/ (Markdown: https://insights.sbomify.com/CVE-2025-2691/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-2691
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-2691
- OSV: https://osv.dev/vulnerability/CVE-2025-2691

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-2691/
Summaries are generated and may contain mistakes; the official description above is the record.
