{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.nifi:nifi-mongodb-services. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-27017 in the wild and no public exploit code.","fix":"Upgrade org.apache.nifi:nifi-mongodb-services to 2.3.0 or later.","what":"CVE-2025-27017 is a medium-severity vulnerability in Apache Nifi, published on 12 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-27017 and fix it if it is affected.\n\nWhat it is: CVE-2025-27017 is a medium-severity vulnerability in Apache Nifi, published on 12 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-27017 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.nifi:nifi-mongodb-services (Maven): affected from 1.13.0; fixed in 2.3.0\n- org.apache.nifi:nifi-mongodb-services (Maven): affected from 1.13.0; fixed in 2.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-27017/ (Markdown: https://insights.sbomify.com/CVE-2025-27017/index.md)","id":"CVE-2025-27017","markdown":"https://insights.sbomify.com/CVE-2025-27017/index.md","name":"CVE-2025-27017","record":{"aliases":["GHSA-35gq-cvrm-xf94"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache NiFi","requires_auth":"high_privilege","summary":"Authorized users can view MongoDB credentials in NiFi provenance events, exposing sensitive authentication data.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"nifi","vendor":"apache"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N/S:P/AU:Y/R:U/V:C/RE:L/U:Green","version":"4.0"},"cwes":[{"id":"CWE-538","name":"Insertion of Sensitive Information into Externally-Accessible File or Directory"}],"description":"Apache NiFi 1.13.0 through 2.2.0 includes the username and password used to authenticate with MongoDB in the NiFi provenance events that MongoDB components generate during processing. An authorized user with read access to the provenance events of those processors may see the credentials information. Upgrading to Apache NiFi 2.3.0 is the recommended mitigation, which removes the credentials from provenance event records.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache NiFi: Potential Insertion of MongoDB Password in Provenance Record","id":"CVE-2025-27017","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"apache:nifi","products":["apache:nifi"],"type":"information_disclosure","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Apache Airflow MySQL Provider: SQL injection in MySQL provider core function","id":"CVE-2025-27018"},"packages":[{"ecosystem":"Maven","fixed":["2.3.0"],"introduced":["1.13.0"],"last_affected":[],"package":"org.apache.nifi:nifi-mongodb-services","purl":null,"source":"GHSA-35gq-cvrm-xf94"},{"ecosystem":"Maven","fixed":["2.3.0"],"introduced":["1.13.0"],"last_affected":[],"package":"org.apache.nifi:nifi-mongodb-services","purl":"pkg:maven/org.apache.nifi/nifi-mongodb-services","source":"GHSA-35gq-cvrm-xf94"}],"prev":{"headline":"WordPress Drivr Lite – Google Drive Plugin plugin \u003c= 1.0.1 - Stored Cross Site Scripting (XSS) vulnerability","id":"CVE-2025-27016"},"products":["Apache NiFi"],"published":"2025-03-12","related":[{"cvss_score":9.8,"headline":"Improper Restriction of XML External Entity Reference in Apache NiFi","id":"CVE-2018-1309","kev_date_added":null,"published":"2018-05-23"},{"cvss_score":9.8,"headline":"Apache NiFi XSS issue in context path handling","id":"CVE-2017-15697","kev_date_added":null,"published":"2018-01-23"},{"cvss_score":9.8,"headline":"Injection in Apache NiFi","id":"CVE-2017-5636","kev_date_added":null,"published":"2017-10-19"},{"cvss_score":8.8,"headline":"Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests","id":"CVE-2026-68981","kev_date_added":null,"published":"2026-08-03"},{"cvss_score":8.8,"headline":"Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources","id":"CVE-2023-36542","kev_date_added":null,"published":"2023-07-29"},{"cvss_score":8.8,"headline":"Apache NiFi: Potential Code Injection with Database Services using H2","id":"CVE-2023-34468","kev_date_added":null,"published":"2023-06-12"},{"cvss_score":8.8,"headline":"Improper Neutralization of Command Elements in Shell User Group Provider","id":"CVE-2022-33140","kev_date_added":null,"published":"2022-06-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-12","vendors":["Apache Software Foundation"]},"summary":"Authorized users can view MongoDB credentials in NiFi provenance events, exposing sensitive authentication data.","url":"https://insights.sbomify.com/CVE-2025-27017/"}