# CVE-2025-27017: Apache NiFi: Potential Insertion of MongoDB Password in Provenance Record

> Authorized users can view MongoDB credentials in NiFi provenance events, exposing sensitive authentication data.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N/S:P/AU:Y/R:U/V:C/RE:L/U:Green`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2025
- **Updated:** 12 Mar 2025
- **Also known as:** GHSA-35gq-cvrm-xf94

## What is CVE-2025-27017?

CVE-2025-27017 is a medium-severity vulnerability in Apache Nifi, published on 12 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Apache NiFi 1.13.0 through 2.2.0 includes the username and password used to authenticate with MongoDB in the NiFi provenance events that MongoDB components generate during processing. An authorized user with read access to the provenance events of those processors may see the credentials information. Upgrading to Apache NiFi 2.3.0 is the recommended mitigation, which removes the credentials from provenance event records.

Weakness: CWE-538 (Insertion of Sensitive Information into Externally-Accessible File or Directory)

## Which versions are affected by CVE-2025-27017?

2 open source packages ship an affected version, including org.apache.nifi:nifi-mongodb-services. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.nifi:nifi-mongodb-services` | Maven | From 1.13.0 | 2.3.0 |
| `org.apache.nifi:nifi-mongodb-services` | Maven | From 1.13.0 | 2.3.0 |

Products: Apache Nifi.

## How do I fix CVE-2025-27017?

Upgrade org.apache.nifi:nifi-mongodb-services to 2.3.0 or later.

## Is CVE-2025-27017 being exploited?

There is no known exploitation of CVE-2025-27017 in the wild and no public exploit code.

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27017 and fix it if it is affected.

What it is: CVE-2025-27017 is a medium-severity vulnerability in Apache Nifi, published on 12 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-27017 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.nifi:nifi-mongodb-services (Maven): affected from 1.13.0; fixed in 2.3.0
- org.apache.nifi:nifi-mongodb-services (Maven): affected from 1.13.0; fixed in 2.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27017/ (Markdown: https://insights.sbomify.com/CVE-2025-27017/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27017
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27017
- OSV: https://osv.dev/vulnerability/CVE-2025-27017

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27017/
Summaries are generated and may contain mistakes; the official description above is the record.
