{"answers":{"affected":"3 open source packages ship an affected version, including apache-airflow-providers-mysql. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-27018 in the wild and no public exploit code.","fix":"Upgrade apache-airflow-providers-mysql to 6.2.0 or later.","what":"CVE-2025-27018 is a medium-severity SQL injection vulnerability in Apache Airflow MySQL Provider, published on 19 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-27018 and fix it if it is affected.\n\nWhat it is: CVE-2025-27018 is a medium-severity SQL injection vulnerability in Apache Airflow MySQL Provider, published on 19 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-27018 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-airflow-providers-mysql (PyPI): affected all versions; fixed in 6.2.0\n- apache-airflow-providers-mysql (PyPI): affected all versions; fixed in 6.2.0\n- apache-airflow-providers-mysql (PyPI): affected all versions; fixed in 6.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-27018/ (Markdown: https://insights.sbomify.com/CVE-2025-27018/index.md)","id":"CVE-2025-27018","markdown":"https://insights.sbomify.com/CVE-2025-27018/index.md","name":"CVE-2025-27018","record":{"aliases":["ECHO-73be-25d4-4d85","GHSA-hhm6-jjf4-6pm3","PYSEC-2026-1151"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Airflow MySQL Provider","requires_auth":"low_privilege","summary":"Attackers can inject SQL via table parameters in DAGs, leading to data corruption or modification in Apache Airflow MySQL Provider.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"apache-airflow-providers-mysql","vendor":"apache"}],"cvss":{"score":6.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Airflow MySQL Provider.\n\nWhen user triggered a DAG with dump_sql or load_sql functions they could pass a table parameter from a UI, that could cause SQL injection by running SQL that was not intended.\nIt could lead to data corruption, modification and others.\nThis issue affects Apache Airflow MySQL Provider: before 6.2.0.\n\nUsers are recommended to upgrade to version 6.2.0, which fixes the issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Airflow MySQL Provider: SQL injection in MySQL provider core function","id":"CVE-2025-27018","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"sql_injection","year":"2025"},"n_packages":3,"n_references":3,"next":{"headline":"Remote shell service (RSH) in Infinera MTC-9","id":"CVE-2025-27019"},"packages":[{"ecosystem":"PyPI","fixed":["6.2.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-mysql","purl":null,"source":"GHSA-hhm6-jjf4-6pm3"},{"ecosystem":"PyPI","fixed":["6.2.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-mysql","purl":"pkg:pypi/apache-airflow-providers-mysql","source":"GHSA-hhm6-jjf4-6pm3"},{"ecosystem":"PyPI","fixed":["6.2.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-mysql","purl":"pkg:pypi/apache-airflow-providers-mysql","source":"PYSEC-2026-1151"}],"prev":{"headline":"Apache NiFi: Potential Insertion of MongoDB Password in Provenance Record","id":"CVE-2025-27017"},"products":["Apache Airflow MySQL Provider"],"published":"2025-03-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-25","vendors":["Apache Software Foundation"]},"summary":"Attackers can inject SQL via table parameters in DAGs, leading to data corruption or modification in Apache Airflow MySQL Provider.","url":"https://insights.sbomify.com/CVE-2025-27018/"}