{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-2704 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-2704 is a high-severity denial of service vulnerability in OpenVPN, published on 2 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-2704 and fix it if it is affected.\n\nWhat it is: CVE-2025-2704 is a high-severity denial of service vulnerability in OpenVPN, published on 2 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-2704 in the wild and no public exploit code.\n\nAffected product: OpenVPN. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-2704/ (Markdown: https://insights.sbomify.com/CVE-2025-2704/index.md)","id":"CVE-2025-2704","markdown":"https://insights.sbomify.com/CVE-2025-2704/index.md","name":"CVE-2025-2704","record":{"aliases":["ALPINE-CVE-2025-2704","CLEANSTART-2026-EP23751","DEBIAN-CVE-2025-2704","GHSA-5gwv-2q72-gxrm","OESA-2025-1396","OESA-2025-1397","SUSE-SU-2025:01508-1","SUSE-SU-2025:1508-1","UBUNTU-CVE-2025-2704","USN-7411-1","openSUSE-SU-2025:14979-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"OpenVPN server","requires_auth":"none","summary":"Remote attackers can cause denial of service in OpenVPN servers by corrupting and replaying packets during the TLS-crypt-v2 handshake.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"OpenVPN","cpe":[{"product":"openvpn","vendor":"openvpn"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-754","name":"Improper Check for Unusual or Exceptional Conditions"}],"description":"OpenVPN version 2.6.1 through 2.6.13 in server mode using TLS-crypt-v2 allows remote attackers to trigger a denial of service by corrupting and replaying network packets in the early handshake phase","ecosystems":["SUSE:Linux Enterprise Module for Basesystem 15 SP6","SUSE:Linux Enterprise Module for Basesystem 15 SP7","openSUSE:Leap 15.6","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in OpenVPN","id":"CVE-2025-2704","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":7,"n_references":2,"next":{"headline":"Digiwin ERP FileUploadApi.ashx DoWebUpload unrestricted upload","id":"CVE-2025-2705"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP6","fixed":["2.6.8-150600.3.17.1"],"introduced":["0"],"last_affected":[],"package":"openvpn","purl":"pkg:rpm/suse/openvpn\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP6","source":"SUSE-SU-2025:1508-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP6","fixed":["2.6.8-150600.3.17.1"],"introduced":["0"],"last_affected":[],"package":"openvpn-dco","purl":"pkg:rpm/suse/openvpn-dco\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP6","source":"SUSE-SU-2025:1508-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP7","fixed":["2.6.8-150600.3.17.1"],"introduced":["0"],"last_affected":[],"package":"openvpn","purl":"pkg:rpm/suse/openvpn\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP7","source":"SUSE-SU-2025:01508-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP7","fixed":["2.6.8-150600.3.17.1"],"introduced":["0"],"last_affected":[],"package":"openvpn-dco","purl":"pkg:rpm/suse/openvpn-dco\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP7","source":"SUSE-SU-2025:01508-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["2.6.8-150600.3.17.1"],"introduced":["0"],"last_affected":[],"package":"openvpn","purl":"pkg:rpm/opensuse/openvpn\u0026distro=openSUSE%20Leap%2015.6","source":"SUSE-SU-2025:1508-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["2.6.8-150600.3.17.1"],"introduced":["0"],"last_affected":[],"package":"openvpn-dco","purl":"pkg:rpm/opensuse/openvpn-dco\u0026distro=openSUSE%20Leap%2015.6","source":"SUSE-SU-2025:1508-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.6.14-1.1"],"introduced":["0"],"last_affected":[],"package":"openvpn","purl":"pkg:rpm/opensuse/openvpn\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:14979-1"}],"prev":{"headline":"Cross-site scripting in Grafana","id":"CVE-2025-2703"},"products":["OpenVPN"],"published":"2025-04-02","related":[{"cvss_score":9.1,"headline":"Memory corruption in OpenVPN","id":"CVE-2025-12106","kev_date_added":null,"published":"2025-12-01"},{"cvss_score":9.1,"headline":"Information disclosure in OpenVPN","id":"CVE-2024-5594","kev_date_added":null,"published":"2025-01-06"},{"cvss_score":9.1,"headline":"Cross-site request forgery in n/a","id":"CVE-2018-7544","kev_date_added":null,"published":"2018-03-16"},{"cvss_score":9,"headline":"Code injection in n/a","id":"CVE-2006-1629","kev_date_added":null,"published":"2006-04-06"},{"cvss_score":8.8,"headline":"Privilege escalation in OpenVPN","id":"CVE-2024-4877","kev_date_added":null,"published":"2025-04-03"},{"cvss_score":7.8,"headline":"Code injection in OpenVPN-GUI","id":"CVE-2021-3606","kev_date_added":null,"published":"2021-07-02"},{"cvss_score":7.8,"headline":"Use after free in n/a","id":"CVE-2018-9336","kev_date_added":null,"published":"2018-05-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-23","vendors":["OpenVPN"]},"summary":"Remote attackers can cause denial of service in OpenVPN servers by corrupting and replaying packets during the TLS-crypt-v2 handshake.","url":"https://insights.sbomify.com/CVE-2025-2704/"}