# CVE-2025-27089: Overlapping policies allow update to non-allowed fields in directus

> Overlapping policies in Directus allow users to modify fields they should not have access to by combining permissions from multiple policies.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2025
- **Updated:** 19 Feb 2025
- **Also known as:** GHSA-99vm-5v2h-h6r6

## What is CVE-2025-27089?

CVE-2025-27089 is a medium-severity missing authorization vulnerability in Monospace Directus, published on 19 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Directus is a real-time API and App dashboard for managing SQL database content. In affected versions if there are two overlapping policies for the `update` action that allow access to different fields, instead of correctly checking access permissions against the item they apply for the user is allowed to update the superset of fields allowed by any of the policies. E.g. have one policy allowing update access to `field_a` if the `id == 1` and one policy allowing update access to `field_b` if the `id == 2`. The user with both these policies is allowed to update both `field_a` and `field_b` for the items with ids `1` and `2`. Before v11, if a user was allowed to update an item they were allowed to update the fields that the single permission, that applied to that item, listed. With overlapping permissions this isn't as clear cut anymore and the union of fields might not be the fields the user is allowed to update for that specific item. The solution that this PR introduces is to evaluate the permissions for each field that the user tries to update in the validateItemAccess DB query, instead of only verifying access to the item as a whole. This is done by, instead of returning the actual field value, returning a flag that indicates if the user has access to that field. This uses the same case/when mechanism that is used for stripping out non permitted field that is at the core of the permissions engine. As a result, for every item that the access is validated for, the expected result is an item that has either 1 or null for all the "requested" fields instead of any of the actual field values. These results are not useful for anything other than verifying the field level access permissions. The final check in validateItemAccess can either fail if the number of items does not match the number of items the access is checked for (ie. the user does not have access to the item at all) or if not all of the passed in fields have access permissions for any of the returned items. This is a vulnerability that allows update access to unintended fields, potentially impacting the password field for user accounts. This has been addressed in version 11.1.2 and all users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-27089?

4 open source packages ship an affected version, including @directus/api and directus. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@directus/api` | npm | From 22.0.0 | 23.1.0 |
| `@directus/api` | npm | From 22.0.0 | 23.1.0 |
| `directus` | npm | From 11.0.0 | 11.1.2 |
| `directus` | npm | From 11.0.0 | 11.1.2 |

Products: Monospace Directus.

## How do I fix CVE-2025-27089?

Upgrade @directus/api to 23.1.0 or later.

## Is CVE-2025-27089 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27089 exists.

## Other vulnerabilities in Monospace Directus

- [CVE-2022-26969](https://insights.sbomify.com/CVE-2022-26969/): Insecure default value for CORS configuration (critical 9.8)
- [CVE-2025-55746](https://insights.sbomify.com/CVE-2025-55746/): Directus allows unauthenticated file upload and file modification due to lacking input sanitization (critical 9.3)
- [CVE-2026-35408](https://insights.sbomify.com/CVE-2026-35408/): Directus is Missing Cross-Origin Opener Policy (high 8.7)
- [CVE-2026-61836](https://insights.sbomify.com/CVE-2026-61836/): Directus: Authorization-dependent response served from unsegmented cache key (high 8.6)
- [CVE-2025-30353](https://insights.sbomify.com/CVE-2025-30353/): Directus's webhook trigger flows can leak sensitive data (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27089 and fix it if it is affected.

What it is: CVE-2025-27089 is a medium-severity missing authorization vulnerability in Monospace Directus, published on 19 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27089 exists.

Affected packages and fixed versions:
- @directus/api (npm): affected from 22.0.0; fixed in 23.1.0
- @directus/api (npm): affected from 22.0.0; fixed in 23.1.0
- directus (npm): affected from 11.0.0; fixed in 11.1.2
- directus (npm): affected from 11.0.0; fixed in 11.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27089/ (Markdown: https://insights.sbomify.com/CVE-2025-27089/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27089
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27089
- OSV: https://osv.dev/vulnerability/CVE-2025-27089

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27089/
Summaries are generated and may contain mistakes; the official description above is the record.
