CVE-2025-27095 JumpServer has a Kubernetes Token Leak Vulnerability

Medium 4.3 Published Updated

Low-privileged users can manipulate kubeconfig to leak Kubernetes tokens, enabling unauthorized cluster access and privilege escalation.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-27095?

CVE-2025-27095 is a medium-severity vulnerability in jumpserver, published on 31 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

JumpServer is an open source bastion host and an operation and maintenance security audit system. Prior to 4.8.0 and 3.10.18, an attacker with a low-privileged account can access the Kubernetes session feature and manipulate the kubeconfig file to redirect API requests to an external server controlled by the attacker. This allows the attacker to intercept and capture the Kubernetes cluster token. This can potentially allow unauthorized access to the cluster and compromise its security. This vulnerability is fixed in 4.8.0 and 3.10.18.

Weakness: CWE-266

Which versions are affected by CVE-2025-27095?

It affects 1 product.

Products include Fit2cloud Jumpserver.

How do I fix CVE-2025-27095?

No fix has been published for CVE-2025-27095 yet. Limit exposure of the affected software until one is available.

Is CVE-2025-27095 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27095 exists.

Sources

Also known as GHSA-5q9w-f4wh-f535.

Is CVE-2025-27095 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free