# CVE-2025-27095: JumpServer has a Kubernetes Token Leak Vulnerability

> Low-privileged users can manipulate kubeconfig to leak Kubernetes tokens, enabling unauthorized cluster access and privilege escalation.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 31 Mar 2025
- **Updated:** 31 Mar 2025
- **Also known as:** GHSA-5q9w-f4wh-f535

## What is CVE-2025-27095?

CVE-2025-27095 is a medium-severity vulnerability in jumpserver, published on 31 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

JumpServer is an open source bastion host and an operation and maintenance security audit system. Prior to 4.8.0 and 3.10.18, an attacker with a low-privileged account can access the Kubernetes session feature and manipulate the kubeconfig file to redirect API requests to an external server controlled by the attacker. This allows the attacker to intercept and capture the Kubernetes cluster token. This can potentially allow unauthorized access to the cluster and compromise its security. This vulnerability is fixed in 4.8.0 and 3.10.18.

Weakness: CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2025-27095?

It affects 1 product.


Products: Fit2cloud Jumpserver.

## How do I fix CVE-2025-27095?

No fix has been published for CVE-2025-27095 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-27095 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27095 exists.

## Other vulnerabilities in jumpserver

- [CVE-2024-40628](https://insights.sbomify.com/CVE-2024-40628/): Arbitrary File Read in Ansible Playbooks in Jumpserver (critical 10.0)
- [CVE-2024-40629](https://insights.sbomify.com/CVE-2024-40629/): Arbitrary File Write in Ansible Playbooks leads to RCE in Jumpserver (critical 10.0)
- [CVE-2024-29201](https://insights.sbomify.com/CVE-2024-29201/): JumpServer's insecure Ansible playbook validation leads to RCE in Celery (critical 10.0)
- [CVE-2024-29202](https://insights.sbomify.com/CVE-2024-29202/): JumpServer vulnerable to Jinja2 template injection in Ansible leads to RCE in Celery (critical 10.0)
- [CVE-2023-48193](https://insights.sbomify.com/CVE-2023-48193/): Security feature bypass in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27095 and fix it if it is affected.

What it is: CVE-2025-27095 is a medium-severity vulnerability in jumpserver, published on 31 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27095 exists.

Affected product: jumpserver. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27095/ (Markdown: https://insights.sbomify.com/CVE-2025-27095/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27095
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27095
- OSV: https://osv.dev/vulnerability/CVE-2025-27095

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27095/
Summaries are generated and may contain mistakes; the official description above is the record.
