# CVE-2025-27100: An authenticated user can crash lakeFS by exhausting server memory


- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Feb 2025
- **Updated:** 21 Feb 2025
- **Also known as:** GHSA-j7jw-28jm-whr6, GO-2025-3479

## What is CVE-2025-27100?

CVE-2025-27100 is a medium-severity vulnerability in treeverse lakeFS, published on 21 Feb 2025. 

### Official description

lakeFS is an open-source tool that transforms your object storage into a Git-like repository. In affected versions an authenticated user can crash lakeFS by exhausting server memory.  This is an authenticated denial-of-service issue. This problem has been patched in version 1.50.0. Users on versions 1.49.1 and below are affected. Users are advised to upgrade. Users unable to upgrade should either set the environment variable `LAKEFS_BLOCKSTORE_S3_DISABLE_PRE_SIGNED_MULTIPART` to `true` or configure the `disable_pre_signed_multipart` key to true in their config yaml.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-27100?

3 open source packages ship an affected version, including github.com/treeverse/lakefs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/treeverse/lakefs` | Go | All versions | 1.50.0 |
| `github.com/treeverse/lakefs` | Go | All versions | 1.50.0 |
| `github.com/treeverse/lakefs` | Go | All versions | 1.50.0 |

## How do I fix CVE-2025-27100?

Upgrade github.com/treeverse/lakefs to 1.50.0 or later.

## Is CVE-2025-27100 being exploited?

There is no known exploitation of CVE-2025-27100 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27100 and fix it if it is affected.

What it is: CVE-2025-27100 is a medium-severity vulnerability in treeverse lakeFS, published on 21 Feb 2025. 
Exploitation: There is no known exploitation of CVE-2025-27100 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/treeverse/lakefs (Go): affected all versions; fixed in 1.50.0
- github.com/treeverse/lakefs (Go): affected all versions; fixed in 1.50.0
- github.com/treeverse/lakefs (Go): affected all versions; fixed in 1.50.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27100/ (Markdown: https://insights.sbomify.com/CVE-2025-27100/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27100
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27100
- OSV: https://osv.dev/vulnerability/CVE-2025-27100

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27100/
Summaries are generated and may contain mistakes; the official description above is the record.
