# CVE-2025-27104: double eval in For List Iter in Vyper

> Vyper compiler flaw allows double evaluation of loop iterators, causing unexpected state changes in smart contracts. Developers should upgrade to patched versions.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Feb 2025
- **Updated:** 22 Feb 2025
- **Also known as:** GHSA-h33q-mhmp-8p67, PYSEC-2025-30

## What is CVE-2025-27104?

CVE-2025-27104 is a low-severity vulnerability in vyperlang vyper, published on 21 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vyper is a Pythonic Smart Contract Language for the EVM. Multiple evaluation of a single expression is possible in the iterator target of a for loop. While the iterator expression cannot produce multiple writes, it can consume side effects produced in the loop body (e.g. read a storage variable updated in the loop body) and thus lead to unexpected program behavior. Specifically, reads in iterators which contain an ifexp (e.g. `for s: uint256 in ([read(), read()] if True else [])`) may interleave reads with writes in the loop body. Vyper for loops allow two kinds of iterator targets, namely the `range()` builtin and an iterable type, like SArray and DArray. During codegen, iterable lists are required to not produce any side-effects (in the following code, `range_scope` forces `iter_list` to be parsed in a constant context, which is checked against `is_constant`). However, this does not prevent the iterator from consuming side effects provided by the body of the loop. For SArrays on the other hand, `iter_list` is instantiated in the body of a `repeat` ir, so it can be evaluated several times. This issue is being addressed and is expected to be available in version 0.4.1. Users are advised to upgrade as soon as the patched release is available. There are no known workarounds for this vulnerability.

Weakness: CWE-662 (Improper Synchronization)

## Which versions are affected by CVE-2025-27104?

3 open source packages ship an affected version, including vyper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vyper` | PyPI | All versions | 0.4.1 |
| `vyper` | PyPI | All versions | 0.4.1 |
| `vyper` | PyPI | All versions | 0.4.1 |

Products: Vyperlang Vyper.

## How do I fix CVE-2025-27104?

Upgrade vyper to 0.4.1 or later.

## Is CVE-2025-27104 being exploited?

There is no known exploitation of CVE-2025-27104 in the wild and no public exploit code.

## Other vulnerabilities in vyperlang vyper

- [CVE-2024-24563](https://insights.sbomify.com/CVE-2024-24563/): Vyper array negative index vulnerability (critical 9.8)
- [CVE-2024-24561](https://insights.sbomify.com/CVE-2024-24561/): Vyper bounds check on built-in `slice()` function can be overflowed (critical 9.8)
- [CVE-2023-39363](https://insights.sbomify.com/CVE-2023-39363/): Vyper incorrectly allocated named re-entrancy locks (critical 9.1)
- [CVE-2022-24845](https://insights.sbomify.com/CVE-2022-24845/): Integer bounds error in Vyper (high 8.8)
- [CVE-2022-29255](https://insights.sbomify.com/CVE-2022-29255/): Multiple evaluation of contract address in call in vyper (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27104 and fix it if it is affected.

What it is: CVE-2025-27104 is a low-severity vulnerability in vyperlang vyper, published on 21 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-27104 in the wild and no public exploit code.

Affected packages and fixed versions:
- vyper (PyPI): affected all versions; fixed in 0.4.1
- vyper (PyPI): affected all versions; fixed in 0.4.1
- vyper (PyPI): affected all versions; fixed in 0.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27104/ (Markdown: https://insights.sbomify.com/CVE-2025-27104/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27104
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27104
- OSV: https://osv.dev/vulnerability/CVE-2025-27104

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27104/
Summaries are generated and may contain mistakes; the official description above is the record.
