# CVE-2025-27105: AugAssign evaluation order causing OOB write within the object in Vyper

> Attackers can exploit an out-of-bounds write in Vyper compiler to execute arbitrary code or modify data in smart contracts.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Feb 2025
- **Updated:** 22 Feb 2025
- **Also known as:** GHSA-4w26-8p97-f4jp, PYSEC-2025-31

## What is CVE-2025-27105?

CVE-2025-27105 is a low-severity memory corruption vulnerability in vyperlang vyper, published on 21 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vyper is a Pythonic Smart Contract Language for the EVM. Vyper handles AugAssign statements by first caching the target location to avoid double evaluation. However, in the case when target is an access to a DynArray and the rhs modifies the array, the cached target will evaluate first, and the bounds check will not be re-evaluated during the write portion of the statement. This issue has been addressed in version 0.4.1 and all users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2025-27105?

3 open source packages ship an affected version, including vyper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vyper` | PyPI | All versions | 0.4.1 |
| `vyper` | PyPI | All versions | 0.4.1 |
| `vyper` | PyPI | All versions | 0.4.1 |

Products: Vyperlang Vyper.

## How do I fix CVE-2025-27105?

Upgrade vyper to 0.4.1 or later.

## Is CVE-2025-27105 being exploited?

There is no known exploitation of CVE-2025-27105 in the wild and no public exploit code.

## Other vulnerabilities in vyperlang vyper

- [CVE-2024-24563](https://insights.sbomify.com/CVE-2024-24563/): Vyper array negative index vulnerability (critical 9.8)
- [CVE-2024-24561](https://insights.sbomify.com/CVE-2024-24561/): Vyper bounds check on built-in `slice()` function can be overflowed (critical 9.8)
- [CVE-2023-39363](https://insights.sbomify.com/CVE-2023-39363/): Vyper incorrectly allocated named re-entrancy locks (critical 9.1)
- [CVE-2022-24845](https://insights.sbomify.com/CVE-2022-24845/): Integer bounds error in Vyper (high 8.8)
- [CVE-2022-29255](https://insights.sbomify.com/CVE-2022-29255/): Multiple evaluation of contract address in call in vyper (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27105 and fix it if it is affected.

What it is: CVE-2025-27105 is a low-severity memory corruption vulnerability in vyperlang vyper, published on 21 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-27105 in the wild and no public exploit code.

Affected packages and fixed versions:
- vyper (PyPI): affected all versions; fixed in 0.4.1
- vyper (PyPI): affected all versions; fixed in 0.4.1
- vyper (PyPI): affected all versions; fixed in 0.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27105/ (Markdown: https://insights.sbomify.com/CVE-2025-27105/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27105
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27105
- OSV: https://osv.dev/vulnerability/CVE-2025-27105

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27105/
Summaries are generated and may contain mistakes; the official description above is the record.
