{"answers":{"affected":"2 open source packages ship an affected version, including dom-expressions. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-27108 in the wild and no public exploit code.","fix":"Upgrade dom-expressions to 0.39.5 or later.","what":"CVE-2025-27108 is a high-severity cross-site scripting vulnerability in ryansolid dom-expressions, published on 21 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-27108 and fix it if it is affected.\n\nWhat it is: CVE-2025-27108 is a high-severity cross-site scripting vulnerability in ryansolid dom-expressions, published on 21 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-27108 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- dom-expressions (npm): affected all versions; fixed in 0.39.5\n- dom-expressions (npm): affected all versions; fixed in 0.39.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-27108/ (Markdown: https://insights.sbomify.com/CVE-2025-27108/index.md)","id":"CVE-2025-27108","markdown":"https://insights.sbomify.com/CVE-2025-27108/index.md","name":"CVE-2025-27108","record":{"aliases":["GHSA-hw62-58pr-7wc5"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"SolidJS DOM library","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript in victim browsers via XSS in dom-expressions when user-controlled data is inserted into meta tags.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"dom_expressions","vendor":"ryansolid"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-116","name":"Improper Encoding or Escaping of Output"}],"description":"dom-expressions is a Fine-Grained Runtime for Performant DOM Rendering. In affected versions the use of javascript's `.replace()` opens up to potential Cross-site Scripting (XSS) vulnerabilities with the special replacement patterns beginning with `$`. Particularly, when the attributes of `Meta` tag from solid-meta are user-defined, attackers can utilise the special replacement patterns, either `$'` or `$\\`` to achieve XSS. The solid-meta package has this issue since it uses `useAffect` and context providers, which injects the used assets in the html header. \"dom-expressions\" uses `.replace()` to insert the assets, which is vulnerable to the special replacement patterns listed above.  This effectively means that if the attributes of an asset tag contained user-controlled data, it would be vulnerable to XSS. For instance, there might be meta tags for the open graph protocol in a user profile page, but if attackers set the user query to some payload abusing `.replace()`, then they could execute arbitrary javascript in the victim's web browser. Moreover, it could be stored and cause more problems. This issue has been addressed in version 0.39.5 and all users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting vulnerability due to improper use of string.replace in dom-expressions","id":"CVE-2025-27108","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Lack of Escaping of HTML in JSX Fragments allows for Cross-site Scripting in solid-js","id":"CVE-2025-27109"},"packages":[{"ecosystem":"npm","fixed":["0.39.5"],"introduced":["0"],"last_affected":[],"package":"dom-expressions","purl":null,"source":"GHSA-hw62-58pr-7wc5"},{"ecosystem":"npm","fixed":["0.39.5"],"introduced":["0"],"last_affected":[],"package":"dom-expressions","purl":"pkg:npm/dom-expressions","source":"GHSA-hw62-58pr-7wc5"}],"prev":{"headline":"Integrated Scripting vulnerable to arbitrary code execution via Java reflection","id":"CVE-2025-27107"},"products":["dom-expressions"],"published":"2025-02-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-24","vendors":["ryansolid"]},"summary":"Attackers can execute arbitrary JavaScript in victim browsers via XSS in dom-expressions when user-controlled data is inserted into meta tags.","url":"https://insights.sbomify.com/CVE-2025-27108/"}