# CVE-2025-27108: Cross-site Scripting vulnerability due to improper use of string.replace in dom-expressions

> Attackers can execute arbitrary JavaScript in victim browsers via XSS in dom-expressions when user-controlled data is inserted into meta tags.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Feb 2025
- **Updated:** 24 Feb 2025
- **Also known as:** GHSA-hw62-58pr-7wc5

## What is CVE-2025-27108?

CVE-2025-27108 is a high-severity cross-site scripting vulnerability in ryansolid dom-expressions, published on 21 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

dom-expressions is a Fine-Grained Runtime for Performant DOM Rendering. In affected versions the use of javascript's `.replace()` opens up to potential Cross-site Scripting (XSS) vulnerabilities with the special replacement patterns beginning with `$`. Particularly, when the attributes of `Meta` tag from solid-meta are user-defined, attackers can utilise the special replacement patterns, either `$'` or `$\`` to achieve XSS. The solid-meta package has this issue since it uses `useAffect` and context providers, which injects the used assets in the html header. "dom-expressions" uses `.replace()` to insert the assets, which is vulnerable to the special replacement patterns listed above.  This effectively means that if the attributes of an asset tag contained user-controlled data, it would be vulnerable to XSS. For instance, there might be meta tags for the open graph protocol in a user profile page, but if attackers set the user query to some payload abusing `.replace()`, then they could execute arbitrary javascript in the victim's web browser. Moreover, it could be stored and cause more problems. This issue has been addressed in version 0.39.5 and all users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2025-27108?

2 open source packages ship an affected version, including dom-expressions. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dom-expressions` | npm | All versions | 0.39.5 |
| `dom-expressions` | npm | All versions | 0.39.5 |

Products: Ryansolid Dom Expressions.

## How do I fix CVE-2025-27108?

Upgrade dom-expressions to 0.39.5 or later.

## Is CVE-2025-27108 being exploited?

There is no known exploitation of CVE-2025-27108 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27108 and fix it if it is affected.

What it is: CVE-2025-27108 is a high-severity cross-site scripting vulnerability in ryansolid dom-expressions, published on 21 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-27108 in the wild and no public exploit code.

Affected packages and fixed versions:
- dom-expressions (npm): affected all versions; fixed in 0.39.5
- dom-expressions (npm): affected all versions; fixed in 0.39.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27108/ (Markdown: https://insights.sbomify.com/CVE-2025-27108/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27108
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27108
- OSV: https://osv.dev/vulnerability/CVE-2025-27108

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27108/
Summaries are generated and may contain mistakes; the official description above is the record.
