{"answers":{"affected":"2 open source packages ship an affected version, including solid-js.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27109 exists.","fix":"Upgrade solid-js to 1.9.4 or later.","what":"CVE-2025-27109 is a high-severity cross-site scripting vulnerability in solidjs solid, published on 21 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-27109 and fix it if it is affected.\n\nWhat it is: CVE-2025-27109 is a high-severity cross-site scripting vulnerability in solidjs solid, published on 21 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27109 exists.\n\nAffected packages and fixed versions:\n- solid-js (npm): affected all versions; fixed in 1.9.4\n- solid-js (npm): affected all versions; fixed in 1.9.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-27109/ (Markdown: https://insights.sbomify.com/CVE-2025-27109/index.md)","id":"CVE-2025-27109","markdown":"https://insights.sbomify.com/CVE-2025-27109/index.md","name":"CVE-2025-27109","record":{"aliases":["GHSA-3qxh-p7jc-5xh6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript UI library","requires_auth":"none","summary":"Attackers can execute arbitrary scripts via unescaped HTML in JSX fragments, requiring users to upgrade the solid-js library.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-116","name":"Improper Encoding or Escaping of Output"}],"description":"solid-js is a declarative, efficient, and flexible JavaScript library for building user interfaces. In affected versions Inserts/JSX expressions inside illegal inlined JSX fragments lacked escaping, allowing user input to be rendered as HTML when put directly inside JSX fragments. This issue has been addressed in version 1.9.4 and all users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Lack of Escaping of HTML in JSX Fragments allows for Cross-site Scripting in solid-js","id":"CVE-2025-27109","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Libmodsecurity3 has possible bypass of encoded HTML entities","id":"CVE-2025-27110"},"packages":[{"ecosystem":"npm","fixed":["1.9.4"],"introduced":["0"],"last_affected":[],"package":"solid-js","purl":null,"source":"GHSA-3qxh-p7jc-5xh6"},{"ecosystem":"npm","fixed":["1.9.4"],"introduced":["0"],"last_affected":[],"package":"solid-js","purl":"pkg:npm/solid-js","source":"GHSA-3qxh-p7jc-5xh6"}],"prev":{"headline":"Cross-site Scripting vulnerability due to improper use of string.replace in dom-expressions","id":"CVE-2025-27108"},"products":["solid"],"published":"2025-02-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-24","vendors":["solidjs"]},"summary":"Attackers can execute arbitrary scripts via unescaped HTML in JSX fragments, requiring users to upgrade the solid-js library.","url":"https://insights.sbomify.com/CVE-2025-27109/"}