# CVE-2025-27109: Lack of Escaping of HTML in JSX Fragments allows for Cross-site Scripting in solid-js

> Attackers can execute arbitrary scripts via unescaped HTML in JSX fragments, requiring users to upgrade the solid-js library.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Feb 2025
- **Updated:** 24 Feb 2025
- **Also known as:** GHSA-3qxh-p7jc-5xh6

## What is CVE-2025-27109?

CVE-2025-27109 is a high-severity cross-site scripting vulnerability in solidjs solid, published on 21 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

solid-js is a declarative, efficient, and flexible JavaScript library for building user interfaces. In affected versions Inserts/JSX expressions inside illegal inlined JSX fragments lacked escaping, allowing user input to be rendered as HTML when put directly inside JSX fragments. This issue has been addressed in version 1.9.4 and all users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2025-27109?

2 open source packages ship an affected version, including solid-js.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `solid-js` | npm | All versions | 1.9.4 |
| `solid-js` | npm | All versions | 1.9.4 |

## How do I fix CVE-2025-27109?

Upgrade solid-js to 1.9.4 or later.

## Is CVE-2025-27109 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27109 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27109 and fix it if it is affected.

What it is: CVE-2025-27109 is a high-severity cross-site scripting vulnerability in solidjs solid, published on 21 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27109 exists.

Affected packages and fixed versions:
- solid-js (npm): affected all versions; fixed in 1.9.4
- solid-js (npm): affected all versions; fixed in 1.9.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27109/ (Markdown: https://insights.sbomify.com/CVE-2025-27109/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27109
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27109
- OSV: https://osv.dev/vulnerability/CVE-2025-27109

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27109/
Summaries are generated and may contain mistakes; the official description above is the record.
