{"answers":{"affected":"2 open source packages ship an affected version, including modsecurity and modsecurity2. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27110 exists.","fix":"Upgrade modsecurity to 3.0.14 or later.","what":"CVE-2025-27110 is a high-severity vulnerability in owasp-modsecurity ModSecurity, published on 25 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-27110 and fix it if it is affected.\n\nWhat it is: CVE-2025-27110 is a high-severity vulnerability in owasp-modsecurity ModSecurity, published on 25 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27110 exists.\n\nAffected packages and fixed versions:\n- modsecurity (Bitnami): affected from 3.0.13; fixed in 3.0.14\n- modsecurity2 (Bitnami): affected from 3.0.13; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-27110/ (Markdown: https://insights.sbomify.com/CVE-2025-27110/index.md)","id":"CVE-2025-27110","markdown":"https://insights.sbomify.com/CVE-2025-27110/index.md","name":"CVE-2025-27110","record":{"aliases":["BIT-modsecurity-2025-27110","BIT-modsecurity2-2025-27110","DEBIAN-CVE-2025-27110","GHSA-42w7-rmv5-4x2j","UBUNTU-CVE-2025-27110","openSUSE-SU-2025:14946-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"ModSecurity library","requires_auth":"none","summary":"Attackers can bypass ModSecurity protections by using encoded HTML entities with leading zeroes, requiring an upgrade to the library.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"modsecurity","vendor":"trustwave"}],"cvss":{"score":7.9,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-172","name":"Improper Encoding or Decoding of Data"}],"description":"Libmodsecurity is one component of the ModSecurity v3 project. The library codebase serves as an interface to ModSecurity Connectors taking in web traffic and applying traditional ModSecurity processing. A bug that exists only in Libmodsecurity3 version 3.0.13 means that, in 3.0.13, Libmodsecurity3 can't decode encoded HTML entities if they contains leading zeroes. Version 3.0.14 contains a fix. No known workarounds are available.","ecosystems":["Bitnami","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Libmodsecurity3 has possible bypass of encoded HTML entities","id":"CVE-2025-27110","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"security_feature_bypass","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Escape Sequence Injection vulnerability in Rack lead to Possible Log Injection","id":"CVE-2025-27111"},"packages":[{"ecosystem":"Bitnami","fixed":["3.0.14"],"introduced":["3.0.13"],"last_affected":[],"package":"modsecurity","purl":"pkg:bitnami/modsecurity","source":"BIT-modsecurity-2025-27110"},{"ecosystem":"Bitnami","fixed":[],"introduced":["3.0.13"],"last_affected":[],"package":"modsecurity2","purl":"pkg:bitnami/modsecurity2","source":"BIT-modsecurity2-2025-27110"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.0.14-1.1"],"introduced":["0"],"last_affected":[],"package":"modsecurity","purl":"pkg:rpm/opensuse/modsecurity\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:14946-1"}],"prev":{"headline":"Lack of Escaping of HTML in JSX Fragments allows for Cross-site Scripting in solid-js","id":"CVE-2025-27109"},"products":["ModSecurity"],"published":"2025-02-25","related":[{"cvss_score":7.5,"headline":"ModSecurity Has Possible DoS Vulnerability","id":"CVE-2025-47947","kev_date_added":null,"published":"2025-05-21"},{"cvss_score":7.5,"headline":"Memory corruption in n/a","id":"CVE-2024-46292","kev_date_added":null,"published":"2024-10-09"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-26","vendors":["owasp-modsecurity"]},"summary":"Attackers can bypass ModSecurity protections by using encoded HTML entities with leading zeroes, requiring an upgrade to the library.","url":"https://insights.sbomify.com/CVE-2025-27110/"}