# CVE-2025-27110: Libmodsecurity3 has possible bypass of encoded HTML entities

> Attackers can bypass ModSecurity protections by using encoded HTML entities with leading zeroes, requiring an upgrade to the library.

- **Severity:** High 7.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Feb 2025
- **Updated:** 26 Feb 2025
- **Also known as:** BIT-modsecurity-2025-27110, BIT-modsecurity2-2025-27110, DEBIAN-CVE-2025-27110, GHSA-42w7-rmv5-4x2j, UBUNTU-CVE-2025-27110, openSUSE-SU-2025:14946-1

## What is CVE-2025-27110?

CVE-2025-27110 is a high-severity vulnerability in owasp-modsecurity ModSecurity, published on 25 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Libmodsecurity is one component of the ModSecurity v3 project. The library codebase serves as an interface to ModSecurity Connectors taking in web traffic and applying traditional ModSecurity processing. A bug that exists only in Libmodsecurity3 version 3.0.13 means that, in 3.0.13, Libmodsecurity3 can't decode encoded HTML entities if they contains leading zeroes. Version 3.0.14 contains a fix. No known workarounds are available.

Weakness: CWE-172 (Improper Encoding or Decoding of Data)

## Which versions are affected by CVE-2025-27110?

2 open source packages ship an affected version, including modsecurity and modsecurity2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `modsecurity` | Bitnami | From 3.0.13 | 3.0.14 |
| `modsecurity2` | Bitnami | From 3.0.13 | None |
| `modsecurity` | openSUSE:Tumbleweed | All versions | 3.0.14-1.1 |

Products: Trustwave Modsecurity.

## How do I fix CVE-2025-27110?

Upgrade modsecurity to 3.0.14 or later.

## Is CVE-2025-27110 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27110 exists.

## Other vulnerabilities in owasp-modsecurity ModSecurity

- [CVE-2025-47947](https://insights.sbomify.com/CVE-2025-47947/): ModSecurity Has Possible DoS Vulnerability (high 7.5)
- [CVE-2024-46292](https://insights.sbomify.com/CVE-2024-46292/): Memory corruption in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27110 and fix it if it is affected.

What it is: CVE-2025-27110 is a high-severity vulnerability in owasp-modsecurity ModSecurity, published on 25 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27110 exists.

Affected packages and fixed versions:
- modsecurity (Bitnami): affected from 3.0.13; fixed in 3.0.14
- modsecurity2 (Bitnami): affected from 3.0.13; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27110/ (Markdown: https://insights.sbomify.com/CVE-2025-27110/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27110
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27110
- OSV: https://osv.dev/vulnerability/CVE-2025-27110

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27110/
Summaries are generated and may contain mistakes; the official description above is the record.
