# CVE-2025-27112: Navidrome has authentication bypass in Subsonic API with non-existent username

> Attackers can bypass authentication in Navidrome's Subsonic API using non-existent usernames to access read-only data like playlists.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2025
- **Updated:** 24 Feb 2025
- **Also known as:** GHSA-c3p4-vm8f-386p, GO-2025-3484

## What is CVE-2025-27112?

CVE-2025-27112 is a medium-severity authentication bypass vulnerability in navidrome, published on 24 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Navidrome is an open source web-based music collection server and streamer. Starting in version 0.52.0 and prior to version 0.54.5, in certain Subsonic API endpoints, a flaw in the authentication check process allows an attacker to specify any arbitrary username that does not exist on the system, along with a salted hash of an empty password. Under these conditions, Navidrome treats the request as authenticated, granting access to various Subsonic endpoints without requiring valid credentials. An attacker can use any non-existent username to bypass the authentication system and gain access to various read-only data in Navidrome, such as user playlists. However, any attempt to modify data fails with a "permission denied" error due to insufficient permissions, limiting the impact to unauthorized viewing of information. Version 0.54.5 contains a patch for this issue.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-27112?

3 open source packages ship an affected version, including github.com/navidrome/navidrome. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/navidrome/navidrome` | Go | From 0.52.0 | 0.54.5 |
| `github.com/navidrome/navidrome` | Go | From 0.52.0 | 0.54.5 |
| `github.com/navidrome/navidrome` | Go | From 0.52.0 | 0.54.5 |

Products: Navidrome Navidrome.

## How do I fix CVE-2025-27112?

Upgrade github.com/navidrome/navidrome to 0.54.5 or later.

## Is CVE-2025-27112 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27112 exists.

Public exploit code:

- Navidrome <=0.54.5 - Authentication Bypass in Subsonic API (nuclei): http/cves/2025/CVE-2025-27112.yaml

## Other vulnerabilities in navidrome

- [CVE-2024-47062](https://insights.sbomify.com/CVE-2024-47062/): Multiple SQL Injections and ORM Leak in navidrome (critical 9.4)
- [CVE-2026-25579](https://insights.sbomify.com/CVE-2026-25579/): Navidrome affected by Denial of Service and disk exhaustion via oversized `size` parameter in `/rest/getCoverArt` and `/share/img/<token>` endpoints (critical 9.2)
- [CVE-2024-41259](https://insights.sbomify.com/CVE-2024-41259/): Navidrome uses MD5 hashing algorithm (critical 9.1)
- [CVE-2025-48949](https://insights.sbomify.com/CVE-2025-48949/): Navidrome allows SQL Injection via role parameter (high 8.9)
- [CVE-2023-51442](https://insights.sbomify.com/CVE-2023-51442/): Authentication bypass vulnerability in navidrome's subsonic endpoint (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27112 and fix it if it is affected.

What it is: CVE-2025-27112 is a medium-severity authentication bypass vulnerability in navidrome, published on 24 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27112 exists.

Affected packages and fixed versions:
- github.com/navidrome/navidrome (Go): affected from 0.52.0; fixed in 0.54.5
- github.com/navidrome/navidrome (Go): affected from 0.52.0; fixed in 0.54.5
- github.com/navidrome/navidrome (Go): affected from 0.52.0; fixed in 0.54.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27112/ (Markdown: https://insights.sbomify.com/CVE-2025-27112/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27112
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27112
- OSV: https://osv.dev/vulnerability/CVE-2025-27112

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27112/
Summaries are generated and may contain mistakes; the official description above is the record.
