{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27134 exists.","fix":"No fix has been published for CVE-2025-27134 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-27134 is a high-severity vulnerability in laurent22 joplin, published on 30 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-27134 and fix it if it is affected.\n\nWhat it is: CVE-2025-27134 is a high-severity vulnerability in laurent22 joplin, published on 30 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27134 exists.\n\nAffected product: laurent22 joplin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-27134/ (Markdown: https://insights.sbomify.com/CVE-2025-27134/index.md)","id":"CVE-2025-27134","markdown":"https://insights.sbomify.com/CVE-2025-27134/index.md","name":"CVE-2025-27134","record":{"aliases":["GHSA-xj67-649m-3p8x"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Joplin server","requires_auth":"low_privilege","summary":"Non-admin users can escalate privileges to admin by modifying the is_admin field via the user patch API endpoint.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"joplin","vendor":"joplin_project"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"Joplin is a free, open source note taking and to-do application, which can handle a large number of notes organised into notebooks. Prior to version 3.3.3, a privilege escalation vulnerability exists in the Joplin server, allowing non-admin users to exploit the API endpoint `PATCH /api/users/:id` to set the `is_admin` field to 1. The vulnerability allows malicious low-privileged users to perform administrative actions without proper authorization. This issue has been patched in version 3.3.3.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2025/CVE-2025-27134.yaml","stars":null,"title":"Joplin 3.3.3 Server - Privilege Escalation"}],"tier":"weaponised"},"has_fix":false,"headline":"Privilege escalation in Joplin server via user patch endpoint","id":"CVE-2025-27134","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"RAGFlow SQL Injection vulnerability","id":"CVE-2025-27135"},"packages":[],"prev":{"headline":"WeGIA has SQL Injection endpoint at 'dao/pet/adicionar_tipo_exame.php' parameter 'tipo_exame'","id":"CVE-2025-27133"},"products":["joplin"],"published":"2025-04-30","related":[{"cvss_score":9.8,"headline":"Joplin Vulnerable to Code Injection","id":"CVE-2022-23340","kev_date_added":null,"published":"2022-02-08"},{"cvss_score":9.7,"headline":"Joplin has a parsing error leading to Cross-site Scripting (XSS)","id":"CVE-2024-40643","kev_date_added":null,"published":"2024-09-09"},{"cvss_score":8.9,"headline":"Arbitrary code execution on click of PDF links in Joplin","id":"CVE-2023-45673","kev_date_added":null,"published":"2024-06-21"},{"cvss_score":8.2,"headline":"Safe mode Cross-site Scripting (XSS) vulnerability in Joplin","id":"CVE-2023-37898","kev_date_added":null,"published":"2024-06-21"},{"cvss_score":8.2,"headline":"Cross-site Scripting (XSS) when pasting HTML into the rich text editor in Joplin","id":"CVE-2023-38506","kev_date_added":null,"published":"2024-06-21"},{"cvss_score":8.2,"headline":"Cross site scripting (XSS) when clicking on an untrusted `\u003cmap\u003e` link in Joplin","id":"CVE-2023-39517","kev_date_added":null,"published":"2024-06-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-30","vendors":["laurent22"]},"summary":"Non-admin users can escalate privileges to admin by modifying the is_admin field via the user patch API endpoint.","url":"https://insights.sbomify.com/CVE-2025-27134/"}