# CVE-2025-27134: Privilege escalation in Joplin server via user patch endpoint

> Non-admin users can escalate privileges to admin by modifying the is_admin field via the user patch API endpoint.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 30 Apr 2025
- **Updated:** 30 Apr 2025
- **Also known as:** GHSA-xj67-649m-3p8x

## What is CVE-2025-27134?

CVE-2025-27134 is a high-severity vulnerability in laurent22 joplin, published on 30 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Joplin is a free, open source note taking and to-do application, which can handle a large number of notes organised into notebooks. Prior to version 3.3.3, a privilege escalation vulnerability exists in the Joplin server, allowing non-admin users to exploit the API endpoint `PATCH /api/users/:id` to set the `is_admin` field to 1. The vulnerability allows malicious low-privileged users to perform administrative actions without proper authorization. This issue has been patched in version 3.3.3.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2025-27134?

It affects 1 product.


Products: Joplin Project Joplin.

## How do I fix CVE-2025-27134?

No fix has been published for CVE-2025-27134 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-27134 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27134 exists.

Public exploit code:

- Joplin 3.3.3 Server - Privilege Escalation (nuclei): http/cves/2025/CVE-2025-27134.yaml

## Other vulnerabilities in laurent22 joplin

- [CVE-2022-23340](https://insights.sbomify.com/CVE-2022-23340/): Joplin Vulnerable to Code Injection (critical 9.8)
- [CVE-2024-40643](https://insights.sbomify.com/CVE-2024-40643/): Joplin has a parsing error leading to Cross-site Scripting (XSS) (critical 9.7)
- [CVE-2023-45673](https://insights.sbomify.com/CVE-2023-45673/): Arbitrary code execution on click of PDF links in Joplin (high 8.9)
- [CVE-2023-37898](https://insights.sbomify.com/CVE-2023-37898/): Safe mode Cross-site Scripting (XSS) vulnerability in Joplin (high 8.2)
- [CVE-2023-38506](https://insights.sbomify.com/CVE-2023-38506/): Cross-site Scripting (XSS) when pasting HTML into the rich text editor in Joplin (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27134 and fix it if it is affected.

What it is: CVE-2025-27134 is a high-severity vulnerability in laurent22 joplin, published on 30 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27134 exists.

Affected product: laurent22 joplin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27134/ (Markdown: https://insights.sbomify.com/CVE-2025-27134/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27134
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27134
- OSV: https://osv.dev/vulnerability/CVE-2025-27134

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27134/
Summaries are generated and may contain mistakes; the official description above is the record.
