# CVE-2025-27143: Beter Auth has an Open Redirect via Scheme-Less Callback Parameter

> Attackers can redirect users to malicious sites via scheme-less URLs in Better Auth, enabling phishing or token theft.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2025
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-hjpm-7mrm-26w8

## What is CVE-2025-27143?

CVE-2025-27143 is a medium-severity vulnerability in better-auth, published on 24 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Better Auth is an authentication and authorization library for TypeScript. Prior to version 1.1.21, the application is vulnerable to an open redirect due to improper validation of the callbackURL parameter in the email verification endpoint and any other endpoint that accepts callback url. While the server blocks fully qualified URLs, it incorrectly allows scheme-less URLs. This results in the browser interpreting the URL as a fully qualified URL, leading to unintended redirection. An attacker can exploit this flaw by crafting a malicious verification link and tricking users into clicking it. Upon successful email verification, the user will be automatically redirected to the attacker's website, which can be used for phishing, malware distribution, or stealing sensitive authentication tokens. This CVE is a bypass of the fix for GHSA-8jhw-6pjj-8723/CVE-2024-56734. Version 1.1.21 contains an updated patch.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2025-27143?

2 open source packages ship an affected version, including better-auth. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `better-auth` | npm | All versions | 1.1.20 |
| `better-auth` | npm | All versions | 1.1.20 |

Products: Better-Auth Better Auth.

## How do I fix CVE-2025-27143?

Upgrade better-auth to 1.1.20 or later.

## Is CVE-2025-27143 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27143 exists.

## Other vulnerabilities in better-auth

- [CVE-2026-53512](https://insights.sbomify.com/CVE-2026-53512/): Better Auth: OAuth refresh-token replay via missing client authentication on oidc-provider and mcp plugins (critical 9.1)
- [CVE-2026-53516](https://insights.sbomify.com/CVE-2026-53516/): Better Auth: Account takeover via OAuth auto-link to unverified pre-registered email (high 8.3)
- [CVE-2024-56734](https://insights.sbomify.com/CVE-2024-56734/): Better Auth has an Open Redirect Vulnerability in Verify Email Endpoint (high 7.9)
- [CVE-2026-53514](https://insights.sbomify.com/CVE-2026-53514/): Better Auth: Unauthorized invitation acceptance via unverified email match in organization plugin (high 7.7)
- [CVE-2026-45337](https://insights.sbomify.com/CVE-2026-45337/): Better Auth: Device authorization approve and deny accept any authenticated session while the user code is pending (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27143 and fix it if it is affected.

What it is: CVE-2025-27143 is a medium-severity vulnerability in better-auth, published on 24 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27143 exists.

Affected packages and fixed versions:
- better-auth (npm): affected all versions; fixed in 1.1.20
- better-auth (npm): affected all versions; fixed in 1.1.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27143/ (Markdown: https://insights.sbomify.com/CVE-2025-27143/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27143
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27143
- OSV: https://osv.dev/vulnerability/CVE-2025-27143

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27143/
Summaries are generated and may contain mistakes; the official description above is the record.
