# CVE-2025-27145: copyparty renders unsanitized filenames as HTML when user uploads empty files

> An attacker can execute arbitrary JavaScript via maliciously named empty files during drag-and-drop uploads, potentially reading user files.

- **Severity:** Low 3.6 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Feb 2025
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-m2jw-cj8v-937r, PYSEC-2026-1278

## What is CVE-2025-27145?

CVE-2025-27145 is a low-severity cross-site scripting vulnerability in 9001 copyparty, published on 25 Feb 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

copyparty, a portable file server, has a DOM-based cross-site scripting vulnerability in versions prior to 1.16.15. The vulnerability is considered low-risk. By handing someone a maliciously-named file, and then tricking them into dragging the file into copyparty's Web-UI, an attacker could execute arbitrary javascript with the same privileges as that user. For example, this could give unintended read-access to files owned by that user. The bug is triggered by the drag-drop action itself; it is not necessary to actually initiate the upload. The file must be empty (zero bytes). Note that, as a general-purpose webserver, it is intentionally possible to upload HTML-files with arbitrary javascript in `<script>` tags, which will execute when the file is opened. The difference is that this vulnerability would trigger execution of javascript during the act of uploading, and not when the uploaded file was opened. Version 1.16.15 contains a fix.

Weakness: CWE-83 (Improper Neutralization of Script in Attributes in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-27145?

3 open source packages ship an affected version, including copyparty. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `copyparty` | PyPI | All versions | 1.16.15 |
| `copyparty` | PyPI | All versions | 1.16.15 |
| `copyparty` | PyPI | All versions | 1.16.15 |

Products: 9001 Copyparty.

## How do I fix CVE-2025-27145?

Upgrade copyparty to 1.16.15 or later.

## Is CVE-2025-27145 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27145 exists.

## Other vulnerabilities in 9001 copyparty

- [CVE-2023-41471](https://insights.sbomify.com/CVE-2023-41471/): Cross-site scripting in n/a (high 7.8)
- [CVE-2025-54796](https://insights.sbomify.com/CVE-2025-54796/): Copyparty is vulnerable to Regex Denial of Service (ReDoS) attacks through "Recent Uploads" page (high 7.5)
- [CVE-2023-37474](https://insights.sbomify.com/CVE-2023-37474/): Path traversal in copyparty (high 7.5)
- [CVE-2025-54589](https://insights.sbomify.com/CVE-2025-54589/): copyparty Reflected XSS via Filter Parameter (medium 6.3)
- [CVE-2023-38501](https://insights.sbomify.com/CVE-2023-38501/): copyparty vulnerable to reflected cross-site scripting via k304 parameter (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27145 and fix it if it is affected.

What it is: CVE-2025-27145 is a low-severity cross-site scripting vulnerability in 9001 copyparty, published on 25 Feb 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27145 exists.

Affected packages and fixed versions:
- copyparty (PyPI): affected all versions; fixed in 1.16.15
- copyparty (PyPI): affected all versions; fixed in 1.16.15
- copyparty (PyPI): affected all versions; fixed in 1.16.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27145/ (Markdown: https://insights.sbomify.com/CVE-2025-27145/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27145
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27145
- OSV: https://osv.dev/vulnerability/CVE-2025-27145

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27145/
Summaries are generated and may contain mistakes; the official description above is the record.
