CVE-2025-27146 Matrix IRC Bridge allows IRC command injection to own puppeted user

Low 2.7 Published Updated

Attackers can inject arbitrary IRC commands executed as their own puppeted user in the Matrix IRC bridge, requiring an upgrade to fix.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-27146?

CVE-2025-27146 is a low-severity command injection vulnerability in matrix-org matrix-appservice-irc, published on 25 Feb 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

matrix-appservice-irc is a Node.js IRC bridge for Matrix. The matrix-appservice-irc bridge up to version 3.0.3 contains a vulnerability which can lead to arbitrary IRC command execution as the puppeted user. The attacker can only inject commands executed as their own IRC user. The vulnerability has been patched in matrix-appservice-irc version 3.0.4.

Weakness: CWE-88, CWE-77

Which versions are affected by CVE-2025-27146?

2 open source packages ship an affected version, including matrix-appservice-irc. It affects 1 product.

PackageAffectedFixed in
matrix-appservice-irc npmAll versions3.0.4
matrix-appservice-irc npmAll versions3.0.4

Products include Matrix Matrix Irc Bridge.

How do I fix CVE-2025-27146?

Upgrade matrix-appservice-irc to 3.0.4 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2025-27146 being exploited?

There is no known exploitation of CVE-2025-27146 in the wild and no public exploit code.

Sources

Also known as GHSA-5mvm-89c9-9gm5.

Is CVE-2025-27146 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free