# CVE-2025-27146: Matrix IRC Bridge allows IRC command injection to own puppeted user

> Attackers can inject arbitrary IRC commands executed as their own puppeted user in the Matrix IRC bridge, requiring an upgrade to fix.

- **Severity:** Low 2.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Feb 2025
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-5mvm-89c9-9gm5

## What is CVE-2025-27146?

CVE-2025-27146 is a low-severity command injection vulnerability in matrix-org matrix-appservice-irc, published on 25 Feb 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

matrix-appservice-irc is a Node.js IRC bridge for Matrix. The matrix-appservice-irc bridge up to version 3.0.3 contains a vulnerability which can lead to arbitrary IRC command execution as the puppeted user. The attacker can only inject commands executed as their own IRC user. The vulnerability has been patched in matrix-appservice-irc version 3.0.4.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command), CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2025-27146?

2 open source packages ship an affected version, including matrix-appservice-irc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-appservice-irc` | npm | All versions | 3.0.4 |
| `matrix-appservice-irc` | npm | All versions | 3.0.4 |

Products: Matrix Matrix Irc Bridge.

## How do I fix CVE-2025-27146?

Upgrade matrix-appservice-irc to 3.0.4 or later.

## Is CVE-2025-27146 being exploited?

There is no known exploitation of CVE-2025-27146 in the wild and no public exploit code.

## Other vulnerabilities in matrix-org matrix-appservice-irc

- [CVE-2022-39203](https://insights.sbomify.com/CVE-2022-39203/): Parsing issue in matrix-org/node-irc leading to room takeovers (high 8.8)
- [CVE-2022-29166](https://insights.sbomify.com/CVE-2022-29166/): Improper handling of multiline messages in matrix-appservice-irc (high 8.0)
- [CVE-2023-38690](https://insights.sbomify.com/CVE-2023-38690/): matrix-appservice-irc IRC command injection via admin commands containing newlines (medium 5.8)
- [CVE-2022-3971](https://insights.sbomify.com/CVE-2022-3971/): matrix-appservice-irc PgDataStore.ts sql injection (medium 4.6)
- [CVE-2022-39202](https://insights.sbomify.com/CVE-2022-39202/): IRC mode parameter confusion in matrix-appservice-irc (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27146 and fix it if it is affected.

What it is: CVE-2025-27146 is a low-severity command injection vulnerability in matrix-org matrix-appservice-irc, published on 25 Feb 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-27146 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-appservice-irc (npm): affected all versions; fixed in 3.0.4
- matrix-appservice-irc (npm): affected all versions; fixed in 3.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27146/ (Markdown: https://insights.sbomify.com/CVE-2025-27146/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27146
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27146
- OSV: https://osv.dev/vulnerability/CVE-2025-27146

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27146/
Summaries are generated and may contain mistakes; the official description above is the record.
