{"answers":{"affected":"1 open source package ship an affected version, including gradle.","exploited":"There is no known exploitation of CVE-2025-27148 in the wild and no public exploit code.","fix":"Upgrade gradle to 8.12.1 or later.","what":"CVE-2025-27148 is a high-severity vulnerability in gradle, published on 25 Feb 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-27148 and fix it if it is affected.\n\nWhat it is: CVE-2025-27148 is a high-severity vulnerability in gradle, published on 25 Feb 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-27148 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- gradle (Bitnami): affected from 8.12.0; fixed in 8.12.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-27148/ (Markdown: https://insights.sbomify.com/CVE-2025-27148/index.md)","id":"CVE-2025-27148","markdown":"https://insights.sbomify.com/CVE-2025-27148/index.md","name":"CVE-2025-27148","record":{"aliases":["BELL-CVE-2025-27148","BIT-gradle-2025-27148","MINI-m8fp-f2fh-j4vv","UBUNTU-CVE-2025-27148"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Gradle build tool","requires_auth":"low_privilege","summary":"Local attackers can escalate privileges by exploiting a race condition in Gradle's native library initialization within the system temporary directory.","user_interaction":"not_required","vuln_class":"race_condition"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-379","name":"Creation of Temporary File in Directory with Insecure Permissions"},{"id":"CWE-378","name":"Creation of Temporary File With Insecure Permissions"}],"description":"Gradle is a build automation tool, and its native-platform tool provides Java bindings for native APIs. On Unix-like systems, the system temporary directory can be created with open permissions that allow multiple users to create and delete files within it. This library initialization could be vulnerable to a local privilege escalation from an attacker quickly deleting and recreating files in the system temporary directory. Gradle builds that rely on versions of net.rubygrapefruit:native-platform prior to 0.22-milestone-28 could be vulnerable to a local privilege escalation from an attacker quickly deleting and recreating files in the system temporary directory.\n\nIn net.rubygrapefruit:native-platform prior to version 0.22-milestone-28, if the `Native.get(Class\u003c\u003e)` method was called, without calling `Native.init(File)` first, with a non-`null` argument used as working file path, then the library would initialize itself using the system temporary directory and NativeLibraryLocator.java lines 68 through 78. Version 0.22-milestone-28 has been released with changes that fix the problem. Initialization is now mandatory and no longer uses the system temporary directory, unless such a path is passed for initialization. The only workaround for affected versions is to make sure to do a proper initialization, using a location that is safe.\n\nGradle 8.12, only that exact version, had codepaths where the initialization of the underlying native integration library took a default path, relying on copying the binaries to the system temporary directory. Any execution of Gradle exposed this exploit. Users of Windows or modern versions of macOS are not vulnerable, nor are users of a Unix-like operating system with the \"sticky\" bit set or `noexec` on their system temporary directory vulnerable. This problem was fixed in Gradle 8.12.1. Gradle 8.13 release also upgrades to a version of the native library that no longer has that bug. Some workarounds are available. On Unix-like operating systems, ensure that the \"sticky\" bit is set. This only allows the original user (or root) to delete a file. Mounting `/tmp` as `noexec` will prevent Gradle 8.12 from starting. Those who are are unable to change the permissions of the system temporary directory can move the Java temporary directory by setting the System Property java.io.tmpdir. The new path needs to limit permissions to the build user only.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Gradle vulnerable to local privilege escalation through system temporary directory","id":"CVE-2025-27148","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"race_condition","year":"2025"},"n_packages":1,"n_references":8,"next":{"headline":"Zulip exports can leak private data","id":"CVE-2025-27149"},"packages":[{"ecosystem":"Bitnami","fixed":["8.12.1"],"introduced":["8.12.0"],"last_affected":[],"package":"gradle","purl":"pkg:bitnami/gradle","source":"BIT-gradle-2025-27148"}],"prev":{"headline":"GLPI Inventory plugin has Improper Access Control Vulnerability","id":"CVE-2025-27147"},"products":["gradle"],"published":"2025-02-25","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-25","vendors":["gradle"]},"summary":"Local attackers can escalate privileges by exploiting a race condition in Gradle's native library initialization within the system temporary directory.","url":"https://insights.sbomify.com/CVE-2025-27148/"}