# CVE-2025-27148: Gradle vulnerable to local privilege escalation through system temporary directory

> Local attackers can escalate privileges by exploiting a race condition in Gradle's native library initialization within the system temporary directory.

- **Severity:** High 8.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Feb 2025
- **Updated:** 25 Feb 2025
- **Also known as:** BELL-CVE-2025-27148, BIT-gradle-2025-27148, MINI-m8fp-f2fh-j4vv, UBUNTU-CVE-2025-27148

## What is CVE-2025-27148?

CVE-2025-27148 is a high-severity vulnerability in gradle, published on 25 Feb 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Gradle is a build automation tool, and its native-platform tool provides Java bindings for native APIs. On Unix-like systems, the system temporary directory can be created with open permissions that allow multiple users to create and delete files within it. This library initialization could be vulnerable to a local privilege escalation from an attacker quickly deleting and recreating files in the system temporary directory. Gradle builds that rely on versions of net.rubygrapefruit:native-platform prior to 0.22-milestone-28 could be vulnerable to a local privilege escalation from an attacker quickly deleting and recreating files in the system temporary directory.

In net.rubygrapefruit:native-platform prior to version 0.22-milestone-28, if the `Native.get(Class<>)` method was called, without calling `Native.init(File)` first, with a non-`null` argument used as working file path, then the library would initialize itself using the system temporary directory and NativeLibraryLocator.java lines 68 through 78. Version 0.22-milestone-28 has been released with changes that fix the problem. Initialization is now mandatory and no longer uses the system temporary directory, unless such a path is passed for initialization. The only workaround for affected versions is to make sure to do a proper initialization, using a location that is safe.

Gradle 8.12, only that exact version, had codepaths where the initialization of the underlying native integration library took a default path, relying on copying the binaries to the system temporary directory. Any execution of Gradle exposed this exploit. Users of Windows or modern versions of macOS are not vulnerable, nor are users of a Unix-like operating system with the "sticky" bit set or `noexec` on their system temporary directory vulnerable. This problem was fixed in Gradle 8.12.1. Gradle 8.13 release also upgrades to a version of the native library that no longer has that bug. Some workarounds are available. On Unix-like operating systems, ensure that the "sticky" bit is set. This only allows the original user (or root) to delete a file. Mounting `/tmp` as `noexec` will prevent Gradle 8.12 from starting. Those who are are unable to change the permissions of the system temporary directory can move the Java temporary directory by setting the System Property java.io.tmpdir. The new path needs to limit permissions to the build user only.

Weakness: CWE-379 (Creation of Temporary File in Directory with Insecure Permissions), CWE-378 (Creation of Temporary File With Insecure Permissions)

## Which versions are affected by CVE-2025-27148?

1 open source package ship an affected version, including gradle.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gradle` | Bitnami | From 8.12.0 | 8.12.1 |

## How do I fix CVE-2025-27148?

Upgrade gradle to 8.12.1 or later.

## Is CVE-2025-27148 being exploited?

There is no known exploitation of CVE-2025-27148 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27148 and fix it if it is affected.

What it is: CVE-2025-27148 is a high-severity vulnerability in gradle, published on 25 Feb 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-27148 in the wild and no public exploit code.

Affected packages and fixed versions:
- gradle (Bitnami): affected from 8.12.0; fixed in 8.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27148/ (Markdown: https://insights.sbomify.com/CVE-2025-27148/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27148
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27148
- OSV: https://osv.dev/vulnerability/CVE-2025-27148

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27148/
Summaries are generated and may contain mistakes; the official description above is the record.
