# CVE-2025-27151: redis-check-aof may lead to stack overflow and potential RCE

> A stack-based buffer overflow in redis-check-aof allows attackers to potentially execute arbitrary code via a crafted file path.

- **Severity:** Medium 4.7 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2025
- **Updated:** 29 May 2025
- **Also known as:** ALPINE-CVE-2025-27151, AZL-63750, BELL-CVE-2025-27151, BIT-keydb-2025-27151, BIT-redis-2025-27151, BIT-valkey-2025-27151, DEBIAN-CVE-2025-27151, ECHO-2645-54d2-b8f2, GHSA-5453-q98w-cmvm, MINI-j42r-qx9v-94xh, MINI-j8pp-gc5x-866c, MINI-qxq9-qvrq-g3r9, SUSE-SU-2025:02190-1, UBUNTU-CVE-2025-27151

## What is CVE-2025-27151?

CVE-2025-27151 is a medium-severity memory corruption vulnerability in redis, published on 29 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Redis is an open source, in-memory database that persists on disk. In versions starting from 7.0.0 to before 8.0.2, a stack-based buffer overflow exists in redis-check-aof due to the use of memcpy with strlen(filepath) when copying a user-supplied file path into a fixed-size stack buffer. This allows an attacker to overflow the stack and potentially achieve code execution. This issue has been patched in version 8.0.2.

Weakness: CWE-20 (Improper Input Validation), CWE-121 (Stack-based Buffer Overflow)

## Which versions are affected by CVE-2025-27151?

3 open source packages ship an affected version, including redis, keydb and valkey. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `redis` | Bitnami | From 7.0.0 | 7.2.9, 7.4.4, 8.0.2 |
| `keydb` | Bitnami | From 7.0.0 | None |
| `valkey` | Bitnami | All versions | 7.2.10, 8.0.5, 8.1.2 |
| `redis` | SUSE:Linux Enterprise Module for Server Applications 15 SP6 | All versions | 7.2.4-150600.3.12.1 |
| `redis` | openSUSE:Leap 15.6 | All versions | 7.2.4-150600.3.12.1 |

Products: Redis Redis.

## How do I fix CVE-2025-27151?

Upgrade redis to a fixed version for your release line: 7.2.9, 7.4.4 or 8.0.2.

## Is CVE-2025-27151 being exploited?

There is no known exploitation of CVE-2025-27151 in the wild and no public exploit code.

## Other vulnerabilities in redis

- [CVE-2022-0543](https://insights.sbomify.com/CVE-2022-0543/): Debian-specific Redis Server Lua Sandbox Escape (critical 10.0, exploited in the wild)
- [CVE-2026-23479](https://insights.sbomify.com/CVE-2026-23479/): redis-server use-after-free in unblock client flow may allow remote code execution (high 7.7)
- [CVE-2026-25243](https://insights.sbomify.com/CVE-2026-25243/): redis-server RESTORE invalid memory access may allow remote code execution (high 7.7)
- [CVE-2025-62507](https://insights.sbomify.com/CVE-2025-62507/): Redis: Bug in XACKDEL may lead to stack overflow and potential RCE (high 7.7)
- [CVE-2025-48367](https://insights.sbomify.com/CVE-2025-48367/): Redis DoS Vulnerability due to bad connection error handling (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27151 and fix it if it is affected.

What it is: CVE-2025-27151 is a medium-severity memory corruption vulnerability in redis, published on 29 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-27151 in the wild and no public exploit code.

Affected packages and fixed versions:
- redis (Bitnami): affected from 7.0.0; fixed in 7.2.9, 7.4.4, 8.0.2
- keydb (Bitnami): affected from 7.0.0; no fix listed
- valkey (Bitnami): affected all versions; fixed in 7.2.10, 8.0.5, 8.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27151/ (Markdown: https://insights.sbomify.com/CVE-2025-27151/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27151
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27151
- OSV: https://osv.dev/vulnerability/CVE-2025-27151

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27151/
Summaries are generated and may contain mistakes; the official description above is the record.
